Limit to number of entries in DNS forwarder?



  • I seem to have hit a limit to the number of entries I can add to the "Host Override" section of the DNS forwarder.

    If I put too many entries in there (in the region of 25-30 but I think it's more a character limit than a row limit) then the entries in "/var/etc/hosts" seem to get truncated (often mid-row, hence my guess on character limit) and obviously dns resolution doesn't work for ones that are missing/corrupt.

    Has anyone else seen the same issue?



  • Any news on that?
    It seems that I hit the same problem today. After adding a new entries the latest ones in a list has disappeared from /etc/hosts, but the entries still appear on the configuration web page.

    Regards,
          Andres



  • Same problem here.
    Reboot solves the problem but I rather not do it every time I add a host  ;)

    There is also an error in the logs files for this file:
    "dhcpleases: /var/etc/hosts changed size from original!"

    I run version:2.1-RELEASE (i386)
    built on Wed Sep 11 18:16:44 EDT 2013
    FreeBSD 8.3-RELEASE-p11



  • Seems that I've found the solution to this problem.. Or unless it is working for me for some time without a problem.

    • Go to "Services: DNS forwarder".

    • Uncheck: "Register DHCP leases in DNS forwarder"

    • Save & Apply

    • Uncheck: "Register DHCP static mappings in DNS forwarder"

    • Save & Apply

    • Re-enable the above and Save & Apply in reverse order

    I'll still checking, but unless now I've my host list complete and without a reboot.


Log in to reply