Carp + bridge = could not find a matching real interface subnet



  • Trying to set up a wifi access point on a primary pfsense box, and a wifi access point on a backup box, with a pfsync cable between them so they can 'see' each other and have one dhcp server and ruleset.  So I created a vlan on the pfsync cable, then bridged the access point interface to the vlan interface on both machines.  DHCP works, all that's left is setting up a virtual ip to use as a gateway on the shared subnet.

    I tried having no interface address on both the vlan and the access point then giving the bridge an address.  Then giving everything an address.  same result:

    php: /firewall_virtual_ip.php: New alert found: Sorry but we could not find a matching real interface subnet for the virtual IP address 192.168.27.1.

    Of course there is a subnet specified.  What am I missing.  Same result whether I tell virtual ip / carp to use the vlan, the bridge or the access point.

    ????



  • So, I turn on spanning tree protocol on both sides of the bridge, to include the wifi, vlan, pfsync and bridge interface…and it all works.


Log in to reply