Sarg and squidguard reports



  • Team,

    How can I enable sarg to show me the denied sites from squidguard?
    I use to be able to see the denied sites from dansguardian but I cant seem to reproduce the same with squidguard.

    Thanks for the help team!



  • Anybody got this working?

    TIA :)



  • I moved to squid3-devel.



  • I got the same question, if u have something, share it please.



  • @periko:

    I got the same question, if u have something, share it please.

    I really don't have a solution to this specific issue.
    I actually made things worst when I moved to squid3-devel and squidguard-squid3.
    squidguard no longer works at all.

    I went back to squid and than went back to dansguardian and I get what I need in the sarg reports.

    squid3-devel actually worked ok. I might go to it in the near future as I saw allot of options that interest me like ssl, etc…

    Regards,



  • @serialdie:

    @periko:

    I got the same question, if u have something, share it please.

    I really don't have a solution to this specific issue.
    I actually made things worst when I moved to squid3-devel and squidguard-squid3.
    squidguard no longer works at all.

    I went back to squid and than went back to dansguardian and I get what I need in the sarg reports.

    squid3-devel actually worked ok. I might go to it in the near future as I saw allot of options that interest me like ssl, etc…

    Regards,

    I eventually installed webmin and the dansguardian module to do reporting… much better than sarg.



  • The point is sarg+squidguard.



  • squid3-dev has a way to integrate squidguard logs on squid.

    If you want to do manually on squid2, follow these steps.

    • Edit sgerror.php and include a div that redirects client to the same page including a sufix on url
    $sge_prefix=(preg_match("/\?/",$cl['u'])?"&":"?");
    $str[] = '< iframe > src="'.$cl['u'].$sge_prefix.'sgr=ACCESSDENIED" width="1" height="1" > < /iframe >';
    
    • add a custom rule on squid gui(or edit squid.inc)  to deny url with this sufix
    acl sglog url_regex -i sgr=ACCESSDENIED
    http_access deny sglog #on squid without authentication
    http_access deny password sglog #on squid with authentication
    


  • Have u try this with squid3+squidguard?



  • @periko:

    Have u try this with squid3+squidguard?

    I have and it works very well.


Log in to reply