Upgrade from 2.0.3 to 2.1 - DHCP and LDAP issue



  • Hi to all,

    I had a problem when I did the upgrade from 2.0.3 to 2.1. My failover group for DHCP doesn't work.
    In the primary (2.0.3)  I have this situation:

    Failover Group                     My State                     Since                       Peer State        Since
    "dhcp0"           communications-interrupted       XXXXXXXXXXXXXXX             normal       XXXXXXXXXXXXXXX

    and in the secodary (2.1) I have this situation:
    Failover Group                           My State       Since             Peer State                 Since
      dhcp_opt3 (INTERNAL_LAN)     recover XXXXXXXXXX unknown-state XXXXXXXXXXXXXXX

    If the primary fails, the secondary does't work.
    Also when I have upgrade the system the LDAP server have been deleted.

    Both FW are VM on ESXi.

    Regards.



  • The log on the primary report: dhcpd:
    Failover CONNECT to dhcp0 rejected: Connection rejected, invalid failover partner.

    The log on the secondary reports:
    dhcpd: failover: disconnect: unknown failover relationship name
    dhcpd: Failover CONNECT from dhcp0: unknown failover relationship name
    dhcpd: failover: link startup timeout


  • Rebel Alliance Developer Netgate

    The versions must match for DHCP failover to work. Upgrade the primary and it will go back to normal.



  • @jimp:

    The versions must match for DHCP failover to work. Upgrade the primary and it will go back to normal.

    But now also the primary is in recover/unknown-state and not assigns me the lease…. ?!?!?!?!?!?


Log in to reply