Tutorial para Apache with mod_security-dev



  • Boa tarde,

    Estou tentando configurar o pacote Apache with mod_security-dev, mais não estou conseguindo, o serviço não inicia.

    Alguém teria um exemplo de configuração?

    aguardo, obrigado.



  • O core team publicou recentemente uma atualização do pacote.

    Já tentou usar a última versão?



  • estou tentando usar a  0.2.1



  • Não consegui fazer funcionar.

    desinstalei o pacote e reinstalei e nada. o serviço não inicia de jeito nenhum.

    Alguma sugestão?



  • o mod_security-dev  ainda está em desenvolvimento(não tive tempo de terminar por questões de compilação de módulos opcionais). Já tentou a outra versão?



  • Não testei o outro pacote, ele não aparece na lista.

    O unico que aparece é o DEV.

    Sou novo no pfsense, estou estudando ele ainda.



  • Acertei alguns parâmetros no pacote e subi a versão para 0.2.3. pelo menos no pfsense 2.1 e serviço já está funcionando novamente.

    Corrigi também o download das regras do modsecurity(OWASP ModSecurity Core Rule Set)



  • @marcelloc:

    Acertei alguns parâmetros no pacote e subi a versão para 0.2.3. pelo menos no pfsense 2.1 e serviço já está funcionando novamente.

    Corrigi também o download das regras do modsecurity(OWASP ModSecurity Core Rule Set)

    Obrigado, o serviço iniciou.

    mais uma coisa, o que devo fazer para reproduzir o seguinte cenário:

    url de acesso: sistema.mundod5.com.br
    site interno: 192.168.1.100:80/sistema

    url de acesso: b2b.mundod5.com.br
    site interno: 192.168.1.100:80/b2b

    ou seja quando a url for acessada ele busca nesse servidor. para isso preciso de outro pacote?



  • Nao precisa de pacote nenhum a mais, basta criar o bakend 192.168.1.100 e depois oa url no virtual fazendo o apontamento…

    Marcellinho,

    segunda vou testar a nova versao, ja tava alterando o inc aqui para corrigir, vou analisar tb o lance dos virtuais hosts :-)

    Valeu



  • No arquivo httpd.conf, a configuração não é alterada.

    estava analisando o arquivo e a primeira configuração que for feita fica permanentemente no arquivo e não é alterada.
    é possível visualizar no final do arquivo.



  • @djgel:

    Nao precisa de pacote nenhum a mais, basta criar o bakend 192.168.1.100 e depois oa url no virtual fazendo o apontamento…

    Marcellinho,

    segunda vou testar a nova versao, ja tava alterando o inc aqui para corrigir, vou analisar tb o lance dos virtuais hosts :-)

    Valeu

    então estava fazendo dessa forma, só que no arquivo httpd.conf foi salva uma configuração permanente que não o sistema funcionar.

    outra coisa quando adicionei outro vhost no logs sempre vinha o seguinte erro.

    apache mod_security package: Could not start daemon on port *:80. Another process is already bound to this port.



  • Mudou a porta do pfsense antes de subir o apache na 80?



  • @marcelloc:

    Mudou a porta do pfsense antes de subir o apache na 80?

    a porta 80 está livre, o pfsense está funcionando na porta 8080 desde a instalação.



  • Se já desabilitou o redirecionamento do webconfigurator e não tem outro serviço na mesma porta, voce pode tentar matar todos os httpds na console e salvar a configuração da gui novamente.



  • @marcelloc:

    Se já desabilitou o redirecionamento do webconfigurator e não tem outro serviço na mesma porta, voce pode tentar matar todos os httpds na console e salvar a configuração da gui novamente.

    Fiz o procedimento acima, mais mesmo assim recebo o erro.

    a primeira configuração feita no virtualhots não funciona bem, mais a partir da segunda funciona parcialmente.

    ex:

    1 config: comprar.casaminha.com.br -> 192.168.1.100/comprar -> não funciona

    2 config: comprar.casaminha.com.br/comprar -> 192.168.1.100/comprar -> funciona

    se no arquivo virtualhosts.conf estiver <location>o proxy retorna um erro de redirecionamento.

    agora se tiver <location comprar="">funciona normal.

    mais como disse, o primeiro virtualhost não funciona depois da primeira configuração.

    configuração do apache.

    balancer srv100 - ip: 192.168.1.100 - port; 80 - ping: 10

    vhosts:
    enable
    comprar.casaminha.com.br

    gzip; yes
    patch: /
    balancer: srv100
    backend: /comprar</location></location>



  • Aí ja estamos discutindo como redirecionar sites.

    Www.teste.com para 192.168.1.x/teste e complicado para fazer porque o retorno para o proxy vem igual. Ai para distinguir o que é do / do que é do /teste é uma tarefa quase impossível.

    Redirecinar / para 192.168.1.1 é tranquilo

    Redirecinar /compra para /compra também é tranquilo.

    Sugiro colocar um redirect em html no / do 192.168.1.x para 192.168.1.x/compras.



  • Consegui o redirecionamento, obrigado pela ajuda.



  • Ou então cria uma regra usando o redirect :)

    RedirectMatch permanent /(.*) https://url/dir/$1

    Talvez funcione tb 100%