WLAN to LAN Bridging Not working in 2.1



  • I've spent days working on trying to bridge my WLAN to my LAN in version 2.1 RELEASE.  I've followed the instructions at this link:  http://forum.pfsense.org/index.php?topic=20917.0.  These instructions also match the instructions in the 2.1 Book.  However, I was not able to obtain a DHCP address from the WLAN.

    After spending a couple of days working on this, I decided to back rev to version 2.0.3.  I configured it exactly the same as in 2.1, and magically it works.  The same config does not work in 2.1.

    Hopefully, I'm missing something.



  • On that page, saw some interesting steps and wondered if you have tried the same:

    I just wanted to add a note that for this type of bridge configuration, sometimes it is useful to assign a MAC address to the bridge interface.  Normally it just gets a random MAC, but this behavior will cause some client systems to notify that you are connecting to a new network or router every time it gets a new random MAC (each time you boot up the router), potentially requiring some kind of firewall setup steps for the new network.  Setting a fixed MAC address on the bridge interface resolves this (MAC address on bridge members is ignored in the type of setup this topic is about).

    I found my missing step.  I needed to redo the LAN ip configuration.  After that, everything seems to be working.

    You can still bridge ports together by just adding them to the bridge, you don't have to assign the bridge interface. It's just better in the long run to do it that way.

    The main problem with failing to assign the bridge interface is that if the interface holding the IP goes down, the whole bridge goes down. When you have the bridge assigned and the IP on the bridge interface, any interface can go down without problems.



  • Yes, I manually assigned a Mac address to the bridge0 interface.
    Yes, I moved the IP from the LAN interface to the bridge0 interface.

    Here's my interface config:
      WAN (wan)              -> vr1        -> 192.168.0.250 (DHCP)
      LAN (lan)                -> bridge0    -> NONE
      WIFI (opt1)              -> ath0_wlan0 -> NONE
      BRIDGE0 (opt2)        -> vr0        -> 192.168.10.1

    Now the crazy thing is, when I first installed version 2.0.3, it was working fine.  Now, several hours later, I can't get a DHCP from this version either.  I'm pulling my hair out over this.  The config seems straightforward, but I'm definitely missing something.

    Also, I added the rule to the WIFI interface to allow UDP 68 to 67 for the DHCP to work.  I also added it on the bridge0 interface just in case.



  • Enabled logging of traffic blocked by default rule, anything noteworthy seen there? Might also consider doing a packet capture on the interface as well, see what or if any traffic is coming over.



  • heavy1metal, one of your previous suggestions turned out to be the trick.

    You can still bridge ports together by just adding them to the bridge, you don't have to assign the bridge interface. It's just better in the long run to do it that way.

    Turns out that if I JUST create the bridge, and not swap the IP Address on LAN and bridge0 interfaces, it works perfectly in both 2.0.3 and 2.1.  I'm obviously doing something wrong during the IP Address swap.  I've tried it using both the GUI and by modifying the .xml config file as suggested in the 2.1 book, both methods seem to not work for me.

    Anyway, I'm happy at this point because I now know how to bridge 2 interfaces(and get it to work).

    Thanks for you help.



  • Awesome, I'm glad that proved to be useful :-) Happy bridging


Log in to reply