WAN setup for BT Infinity PPPOE



  • All,

    I'd like some assistance setting up pfSense for BT Infinity in the UK. I have a business connection with 5 static IP addresses.

    I've installed pfSense onto an HP Microserver with the WAN port being em0 (a PCI intel NIC I added) and LAN being bge0 (the onboard ethernet).

    In the web gui I set the WAN connection up as PPPOE and used the same username and password as I do on the homehub that this is replacing.

    No matter what I do, I cannot get the WAN working. LAN works fine, and I can connect to the web UI from another host on my network. The WAN just has a red x on it and if I mouse over it says 'WAN disabled'

    WAN on dashboard

    PPPOE Settings

    PPP Log entries

    My connection is as follows:

    ISP Wall socket –-> Modem ---> em0 on pfsense box

    I believe the modem is a Huawei but it's branded as an Openreach fibre modem.

    Does anyone know what I might need to change to get this working? I know that other people have BT infinity working with pfSense, so I believe it is supported. I just don't know how :)



  • Hi,

    Why you don't setup your BT Openreach modem for IP Passthrough ?
    Like that the Modem-Router will do the PPPoE.
    IP Passthrough will set in DHCP your pfSense WAN port with the current public IP.

    ISP Socket => BT Modem-Router => pfSense
                            192.168.1.1              WAN : 192.168.1.33 private (This is the IP pfSense WAN port will get before enabling Ip Passthrough, for example)

    After IP Passthrough enable in the BT Modem Router
    ISP Socket => BT Modem-Router => pfSense
                            192.168.1.1              WAN : X.X.X.X public

    Regards



  • @OmAr786:

    Why you don't setup your BT Openreach modem for IP Passthrough ?

    I don't have any details for connecting to the modem. From what I can tell, they are supplied locked - http://forums.thinkbroadband.com/general/4197866-bt-wholesale-locking-fibre-modems-is-wrong.html?page=6&sb=7&fpart=all

    Like that the Modem-Router will do the PPPoE.
    IP Passthrough will set in DHCP your pfSense WAN port with the current public IP.

    ISP Socket => BT Modem-Router => pfSense
                            192.168.1.1              WAN : 192.168.1.33 private (This is the IP pfSense WAN port will get before enabling Ip Passthrough, for example)

    After IP Passthrough enable in the BT Modem Router
    ISP Socket => BT Modem-Router => pfSense
                            192.168.1.1              WAN : X.X.X.X public

    If I was to buy a replacement modem, would I need to set that up in IP Passthrough mode and setup PPPoE on the modem ?



  • Can you please send me the exact model number of your modem ?
    It is a modem only or a modem-Router ?
    If it's a modem only, you probably can't manage it.

    If you buy another equipement, buy a modem-router with the ip passthrough feature.
    BT have those kind of modem-router

    I configured one of those in ip passthrough with a commercial firewall for a customer in UK.


  • Netgate Administrator

    The standard fttc modem used by BT used to be the Huawei HG612, they seem to be using others now though. Whilst the hg612 is in fact a modem-router it is locked in modem passthrough mode by BT. They also supply a router which talks to the modem via a standard pppoe connection. What isn't standard though is the username/password. For domestic users all homehub routers send the same username and no password, bt know who you are by what line you're connecting on. pfSense doesn't allow you to not send a password but sending a random one doesn't seem to matter. I've never tried to use s business connection.

    Steve



  • I changed absolutely nothing, and the PPPoE connection came up at about 23:00 last night. It seems that the routing of IPs is all working too - all I need to sort now is the private network side of things.

    Thanks for coming back to me - I'm going to try and replicate what went wrong and update people :)



  • I currently have the same issue :(

    EDIT: Okay I have managed to get it working, it turned out for some really odd reason the network port the PPPoE was on wasnt the correct one, in fact it wasnt anything…

    As shown there is now the interface (alc0) for PPPoE but before hand there was nothing shown here also...

    So using the webconfigurator all I did was assign the WAN to alc0 (MY direct incoming connection (ISP infinity cable coming from the VDSL modem) using the assign interfaces, then I went into the settings specifically for WAN and configured it like so…

    Then as if by magic it suddenly started working, and the right interface was assigned to WAN