LCD support on UTM-1 570 hardware

  • Hello everyone,

    I've found a couple of forum posts indicating that people have been successful running on old Checkpoint hardware.  I've got the 2.1 release installed on an old UTM-1 570 unit.  So far things are fine.  These units have an LCD panel on the front and I'd like to use it for displaying time, uptime, etc. if possible.  I did find the LCDproc package and have installed it, but I'm not having any luck getting it to work.  It appears that the package is designed to be able to drive a wide variety of hardware configurations so I'm optimistic it can be done, but I was hoping either that someone might already have done so and could give me details on the configuration parameters, or that someone can point me to a resource for determining the specifics of both the hardware and the nuances of LCDproc.


  • Netgate Administrator

    Nothing much from a quick Google on this.
    Give us more information on the hardware. What is the display hardware? How is it connected?


  • Just curious - how did you load PFSense on the 570? I was thinking about doing the same (I have a 270 sitting unused).


  • More info on the hardware is actually part of the challenge.  I don't really know any more about it other than it's a 2x16 LCD.  I can pull it apart and try to get some more detail but I was hoping someone had actually done it already and I wouldn't have to.  I did find some command line tools from the original SPLAT install that would manipulate the display but they're linux binaries so I'm assuming I'm not going to have any luck with them on BSD.

    I considered myself very lucky when I actually managed to get something loaded on it.  It has USB ports and based on the BIOS should be able to boot from those or from the network, but I had no luck with either.  Granted, the network boot isn't something I've ever done so that could just be my lack of knowledge.  I just took a stab in the dark and actually did the initial install on a generic PC then moved the disk over into the 570 box.  Bingo!  I was really happy!

  • Netgate Administrator

    There are instructions for reinstalling the checkpoint OS from a USB stick so it should be possible to boot from USB.

    If you write the memstick-serial image to a usb stick you should be able to boot from that and install via the serial console.


  • I actually did attempt several similar methods using bootable USB instructions/tools from various sources.  All were unsuccessful which is when I tried the install/move option which finally got things running.

    Unfortunately the CP instructions (at least the ones that I've found) make use of a tool (ISOMorphic) that is only available if you have an active support account.  If you can point me to something else (or a source for the tool) I'd be grateful.  I've got access to some more of these units and would love to be able to easily retask them with this method.

  • Netgate Administrator

    What did you try do far? Isomorphic might not be any good with a bsd image anyway.

    I would try writing the memstick-serial image with either physdiskwrite or Win32 Disk Imager.


  • I'd actually tried both those already during my attempts to load various fw distros to this hardware.

    As I recall I tried plugging in USB CD drives, USB hard drives, USB floppies, flash drives, adding an IDE CD to the mix since the unit has an IDE port, added a video card for output.  Let's see, did I miss anything?  Nope, I think that pretty much covers all the combinations I tried.  :D

    Essentially nothing I attempted got the unit to actually boot from the USB despite the fact that the BIOS and all the menu options at startup appear to allow you set it up and select it.  I have to admit that I didn't try any of this on a different unit, so I suppose it is possible this one is just bad, but short of that I kind of ran out of ideas.  Anyway, that problem was readily solved once I thought to install it elsewhere and move the drive.  It worked without any issues so I've really moved on to getting something displayed on the LCD.

    Oh yeah, I almost forgot.  All the flash variants I tried did in fact boot from other hardware, just as a sanity check to make sure the image was valid.

    Can anyone tell me what pieces of information I might be able to supply that would help in that quest? I'm game to dismantle the LCD assembly far enough to try and get some manufacturer markings, etc., if that will help.  If no one knows how to cross reference the data then I won't waste my time.  It isn't preventing things from working, it just would be nice to have, even if I could do something trivial like display the time, or hostname, or pretty much anything.  You know, just sort of a geeky thing to make it own. :D

  • Netgate Administrator

    Any information you can find on the LCD will help. Simply Googling the model number + lcdproc usually gives results. It shouldn't be necessary to dismantle too much to find it either. Determining what sort of port it's connected to on the board is also very useful.


  • I know this is a really old post and sorry for the bump But I can provide more information on this - with hopes of getting my display to work also ( just chucked pfsense on a couple of utm-1 570s)

    The display is a Gi Far 16x2, Model on the board is gfc160235-bnfe-jp01 (however not much results in google)

    Display looks similar to this - and part number is similar also; GFC1602M-BNFA-JP13 -

    The display (from power-on) just shows "Initializing Please wait…"

    However its attached to another board via 15 pin header that has 3 inputs; (has a few numbers on it, but no names and no google results at all)

    1. RS-232 (Connected to com2 on the motherboard via 3 pins (Red, yellow, black))
    2. Power
    3. input for front buttons (Up, Down, Escape, Enter)

    I hope someone can shed some light on this, as having even simple information on this display would be awesome :)


  • Any luck with the LCD display ….. any input would be great.


  • Netgate Administrator

    Looks like there's two types. The one with rubber button looks like it's the EZIO display as used in other checkpoint models. That should be at least partially supported. The other one is probably compatible.



  • Seems to me, the easiest thing is to replace the LCD with a LCDC-compat unit, of the same size, but u lose the input buttons of course.

    Looked briefly at LCDC, asking for a 4-row display if want to display bandwidth, and text only. I have used Windows variants, on Windows clients of course and the software there is more sophisticated, allowing bar graph for example. LCDC looks to me is been staying very basic.

  • Netgate Administrator

    The easiest thing would be to just ignore it or cover it up but where's the fun in that.  ;)


  • still no luck. …....

    tried various settings with lcdproc package.

    I hate that blue screen saying "Initializing ...... Please wait....."

  • Netgate Administrator

    So what exactly did you try?

    You loaded the with ezio driver?

    You set lcdd.conf to use it?

    Do you have the rubber key model? Can we see a picture of it?


Log in to reply