Chromecast



  • My apologies in advance if I'm posting twice. I posted about issues that a friend of mine is having with his Chromecast but when I came by to check replies I don't see any trace of it.

    I hooked a friend up with PfSense and he is loving it but he just brought a Chromecast and it is not working. Here are the screens that he is getting:


    A quick check of his DHCP status shows that it did indeed get an IP but for some reason PfSense is blocking it's connections going out to google.

    Here is what I have done so far:

    1. Turned uPNP on
    2. Installed Avahi (Read some where on here that this might help)
    3. Created a rule on my LAN allowing Chromecast IP to any connection even though the default any to any connection should work.

    I have searched to see if there were any ports that I can open up but you can see from the blocks PfSense is blocking https connections from Chromecast to Google. I'm not sure if this is the root cause of the issue but I believe that it has something to do with what's going on.

    I saw on a 2.1RC post that Jimp was waiting for his Chromecast to be delivered but there was no information after that. How did that go for you?

    Here is some information about his network:

    PfSense box is a Dell Optiplex 755 mini (Core 2 Duo /w 2GB of RAM and 80GB Hard Drive) Running 2.1 Release 64bit
    Packages Avahi
    PfSense box is connected to an HP Procurve 2610-48 PWR
    One of the ports is connected to an BelAir Access Point 2.4/5 Ghz

    Anyone have success with chormecast through PfSense?



  • I have a chromecast behind a pfsense FW and it works with no problem.
    To even get a block in that direction means that the default LAN rule was modified or removed to do egress filtering. Is that the case?
    The only other reason is that the IP address it is using is not part of the LAN subnet (which the default rule for LAN allows).

    One other thing, your AP needs to allow WIFI connected devices to talk to each other. I am using DDWRT which by default didn't allow that communication. Once I had that option allowed, it worked without any issues. It also updates with google from time to time.


  • Rebel Alliance Developer Netgate

    My Chromecast works fine. Zero issues, worked out of the box, and I have a relatively complex pfSense config.

    The main thing that seems to get people is that it has 8.8.8.8/8.8.4.4 hardcoded in the Chromecast for DNS. So if they have any kind of DNS restrictions it can mess with it.

    Those blocks in the firewall wouldn't be related.



  • I found the issue and it was unrelated to PfSense. The access point that he is using has AP isolation turned on by default. In order to get things working I had to enable a setting called "Allow Intra-AP communication" and all is well now. Thanks for everyone's help.


Log in to reply