Squid derrubando conexão



  • Olá pessoal, quanda essa opção "Allow users on interface" está habilitada no Proxy Server ninguém na rede consegue acessar a internet. O que pode ser?

    Descrição do campo:
    If this field is checked, the users connected to the interface selected in the 'Proxy interface' field will be allowed to use the proxy, i.e., there will be no need to add the interface's subnet to the list of allowed subnets. This is just a shortcut.



  • Na aba: Acces Control, no vampo: Allowed subnets colocou a sua rede? Ex: 192.168.1.0/24



  • Sim. Não sei o que pode ser. Será que se eu desinstalar e instalar novamente funciona?

    Eu instalei, e em seguida subi as configurações de uma backup que tinha aqui da versão do pfsense 2.0.1.

    Tenho medo de desinstalar e dar problema no pfsense. Não pode parar aqui na empresa.

    Imagens com as configurações.




  • Existe alguma outra configuração fora do Squid que anule o proxy? Pq ao meu ver ta tudo corretamente configurado, mas nada ta sendo filtrado mesmo estando como transparente. Não sei mais o que pode ser.



  • Antonio Emiliano,
    Tente o seguinte:

    1- Habilite a caixa "Allow users on interface".
    2- Deixe o campo "Use alternate DNS-servers for the proxy-server" em branco.
    3- Não é necessário colocar sua subnet da inteface LAN na aba > Acces Control, no campo Allowed subnets.
    4- Reinicie o Squid.

    Se não funcionar, verifique suas regras na LAN e posicionamento. Você desabilitou a "Default allow LAN to any rule"?



  • Muito obrigado johnnybe. Resolveu. A regra na Lan já não existia. Acho que o único problema era porque eu não tava restartando o squid depois das configurações. Sempre que habilitava a "allow users on interface" a navegação para totalmente. Muito obrigado mesmo.



  • @Antonio:

    Muito obrigado johnnybe. Resolveu.

    Legal! E obrigado pelo "Thanks".  8)