Disk boot hangs immediately



  • An old Pentium 4 HT with 4*512MB DDR1, Intel Pro/100 and IDE on an Intel motherboard with Seagate Barracuda 80GB PATA in white box, ran perfectly until retired in favor of a 64 bit, faster machine.  Plugged in various PCI NICs, all with same failure:

    Boot 2.1 Live CD
    Select (I)nstall,
    Use default options
    Get a few acd0: FAILURE - READ_BIG ILLEGAL REQUEST asc=0x64 ascq=0x00 - various pages say it's normal BSD info to be ignored
    Let it finish installing and reboot
    Remove CD

    (PC Reboots)
    F1  pfSense

    F6 PXE
    Boot: F1
    \

    and it hangs on that backslash.



  • I tried a different PC and got the same result.  Then I read another posting about 2.1 issues:

    http://forum.pfsense.org/index.php/topic,69261.0.html

    I downloaded and installed 2.0.3 and it's working perfectly.  As I wrote in that thread I'll be happy to send in any dumps or other diagnostic information requested.


  • Netgate Administrator

    2.1 has better support for sata interfaces which is obviously a good thing. However in some systems this has resulted in the drive bring recognised by a different driver and not booting.
    Try changing the sata mode in the BIOS.

    https://doc.pfsense.org/index.php/Boot_Troubleshooting#BIOS.2FDisk_Errors

    Steve