Going to our domain take us to the router!



  • Hello!

    Long time since I logged in here, but now I ended up with a problem that is probably easy to fix.  :P

    I have put up a box with pfSense, and after that a switch where we got a webserber connected where we are hosting 3 domains.
    My pfSense is using one of the as domain, and now when I´m trying to do a normal surf to one of the sites I ended up going to the https:// and got a DNS error.

    The problem is I need the webGUI, but I don´t want the traffic to being redirected to the webGUI when entering one of this domains.

    How to solve this? :)

    Cheers
    Pontus



  • Change the web gui to something other than port 80.



  • @chpalmer:

    Change the web gui to something other than port 80.

    Edit: Sorry, did not work! Changed it to another port but we are still going to the pfSense webGUI! :/



  • System -> Advanced -> Admin Access
    CHECK Disable webConfigurator redirect rule then it will work.

    Optional:
    CHECK Disable DNS Rebinding Checks
    CHECK Disable HTTP_REFERER enforcement check

    It will work.

    Regards,
    M



  • @maverick_slo:

    System -> Advanced -> Admin Access
    CHECK Disable webConfigurator redirect rule then it will work.

    Optional:
    CHECK Disable DNS Rebinding Checks
    CHECK Disable HTTP_REFERER enforcement check

    It will work.

    Regards,
    M

    Checking the Disable webConfig is working sort of, now we can´t even surf to the our domains at all! :/ Have tried the other ones also with the same result…


  • Rebel Alliance Global Moderator

    Ok lets get some actual info to work with here.

    So you say domains you mean a fqdn your trying to get to that resolves to what IP, public - if so where are you trying to get there from, the internet or from your lan behind pfsense, where these http servers are located?

    And your using a public domain on pfsense?  That resolves on the public internet?

    If you want to host http on servers behind pfsense.  That is fine - how many public IPs do you have, how many servers do you have behind pfsense?

    Lets say server behind pfsense is 192.168.1.100/24 while pfsense lan IP is 192.168.1.1/24 and your public IP is say 1.2.3.4

    you have domainx.com - and on the public internet the fqdn www.domainx.com resolves to 1.2.3.4

    So on pfsense you forward http to 192.168.1.100

    Done, now if you want to access this site www.domainx.com from the public internet your good, if you want to access this from say some other computer 192.168.1.42 behind pfsense then you need to enable nat reflection, or you need to setup your network so that www.domainx.com from your network resolves to the local 192.168.1.100 address.

    So if you give us some actual details to work with, more than happy to help you work out your issues.  But currently have nothing to go on.

    This is gibberish without some detail and context to fill it out

    "when I´m trying to do a normal surf to one of the sites I ended up going to the https:// and got a DNS error."



  • Trying to sort it out right now with the info:

    The box is setup with a static IP from our provider, the LAN is then setup with 10.1.x.x and the domain in the setup of pfSense is set to one of our domains, and therefore the box is named NAME.domain.XXX when we check our network.

    The webserver is connected via a switch and is set to recive a static IP from pfSense, and the NAT is configured to pass MS RDP, 80, 443 and 21 directly to the webserver.

    Cheers


  • Rebel Alliance Global Moderator

    so pfsense is pfsense.domain.tld

    And you have a host record in your dns forwarder for your webserver IP in pfsense that points to 10.1.x.x address of your webserver?

    So I have a sim setup.. pfsense is

    C:>dig pfsense.local.lan +short
    192.168.1.253

    So all of my machines have IPs setup in pfsense - see screenshot below

    C:>dig i5-w7.local.lan +short
    192.168.1.100

    so when you try and query for your webservers fqdn something.yourdomain.tld – what do you get?  See my examples above where my hosts resolve to their local address.

    Are you not using pfsense for dns?

    Does your fqdn resolve to public IP?  If this resolves to pfsense WAN IP, then you need to enable nat reflection for it to work.

    On a side note - I would not forward windows remote desktop into your network..  If you need to allow remote desktop to your machines on your network, its more secure to vpn into your network, and then access the resources you need.




  • Sorry for late reply…

    Haven´t sorted this out yet, and need to take some time to solve this.


  • Rebel Alliance Global Moderator

    Well when you actually provide some details to work with, happy to help you solve your issue.