Problemas no Upload



  • Bom dia,

    Estou a alguns dias tentando resolver um problema no pfsense.

    Instalei o pfsense no virtual box para que ele conecte com o pfsense da matriz e faça o roteamento interno. Utilizei o Openvpn com chave compartilhada e tudo está funcionando bem nesta parte.

    O problema que estou enfrentando é com o upload de qualquer coisa para a internet, ele está bloqueando e não consigo descobrir onde está o erro. Tanto dentro do Oulook como no webmail quando vou anexar algo ele da erro e não completa. Também tentei enviar um arquivo via sendspace para verificar se o erro não estava no protocolo de e-mail mas sem sucesso também.

    Já tentei instalar uma versão mais antiga do virtualbox e também do pfsense porém sem sucesso.

    Alguém tem alguma idéia do que pode ser isso?

    Obrigado a todos

    Erik



  • Onde está sua saída para a Internet?

    Virtualbox não é uma boa opção para serviços em produção.  Use ele somente para testes e laboratórios.



  • Tem um roteador (tplink) para saida.

    Eu já utilizei o pfsense em outros lugares para fazer isso e não tive problemas, e as duas ultimas instalações que fiz estão apresentando o mesmo problema. Tudo funciona menos o upload. Estou no site speedtest ele reconhece o 10mb de download mas no upload ele da erro.



  • rede -> pfsense no virtualbox -> tplink –------> pfsense remoto -> internet?



  • Modem NET –->  TPLINK ----> Virtualbox/pfsense (2 placas virtuais) ---> placa em1 (WAN) DMZ no tplink, placa em0 (Lan) GW da rede interna.



  • @eriksobral:

    Modem NET –->  TPLINK ----> Virtualbox/pfsense (2 placas virtuais) ---> placa em1 (WAN) DMZ no tplink, placa em0 (Lan) GW da rede interna.

    fisicamente quantos segmentos de rede você tem? está "misturando" duas redes no mesmo segmento?

    a faixa de ip do tplink é a mesma da lan do pfsense?



  • o tplink é o ip 192.168.10.1, a WAN esta com 192.168.10.60 e a Lan 192.168.10.2



  • Seu problema não é upload mas sim a não segmentação da rede.



  • Marcelloc,

    A única coisa que não entendo é como isso funciona em alguns lugares e de repente nessas duas ultimas instalações deixou de funcionar, mas vou fazer o teste de alterar os ips e te dou um retorno sobre.



  • Marcelloc,

    Apenas para entender, no caso da virtualbox com pfsense como seria o ideal dos ip's? uma das placas deveria ficar em NAT?



  • Independente da ferramenta, não misture as redes no mesmo segmento.

    Uma rede separa da para WAN e outra para LAN.



  • Marcelloc,

    Mesmo separando não deu certo, fiz o teste instalando um Ubuntu e ativando o compartilhamento funciona bem o upload, então já eliminei a possibilidade de ser a virtual box, vou continuar testando por aqui.



  • separou as redes e os ips?



  • Separei sim, mas não resolveu.

    Tirei o pfsense e coloquei um debian fechando a vpn e compartilhando e agora está funcionando bem. Mas ainda vou fazer novos testes para tentar identificar onde está o problema.