Squid not working



  • Hi I am new to FreeBSD, Pfsense, and squid… well all linux/unix stuff in general.

    I have installed pfSense and it is functioning perfectly. I also installed the squid package and squidlight packages.

    I have this setup in a computer store, where we have a need to make the cacheing transparent.

    I have bound it to the LAN, checked the transparent box. The reporting shows over the last three days downloads of 1.25GB.
    So it is obviously caching the files. But when we go to get the files again, the speeds we are getting cannot be coming from the
    local hard drive.

    So I tried adding these lines to the custom configuration:

    httpd_accel_host virtual
    httpd_accel_port 80
    httpd_accel_with_proxy on
    httpd_accel_uses_host_header on
    http_port 192.168.2.1:3128 transparent

    How can I get this working?

    Specifications are as follows:
    P3 800Mhz
    512MB 333Mhz
    80GB Hard drive (2nd problem here, see later).
    Minimum File Size 2KB
    Maximum File Size 307,200KB
    Memory for cache 192MB

    Any help would be appreciated...

    2nd problem.... not so important though.
    When I install any version of pfSense.... on any hard drive (have tried bad 80, used 40, and now new 80)
    The initial install goes through fine and suggests geometry covering the entire drive.
    after reboot I get "cannot load kernel"

    I go through installation again.
    This time it suggests geometry 1/4 the drive size (approx)
    When it formats it gets error code 1, I skip the step..
    It says "formated successfully". continues on... and then works after reboot.

    Any ideas?

    Thanks for your help. ???



  • Just to clarify.
    Our connection is 10Mb Down, 3Mb Up.

    We generally get on average 600KB download speeds.
    On great sites, I have seen a max speed of 1.25MB/s

    The speeds I am getting are the same as the original download of about 600KB.

    Quite some time ago we had a Mikrotik router, which served cached files in excess of 2MB/s

    Even 1MB/s on windows updates would greatly make things easier.

    Thanks.



  • As far as issues with the disk go, try setting different modes in your BIOS.  The one that has brought me the most success in these types of scenarios is LBA mode.



  • Following Justinw's advice (thanks by the way).

    I set the BIOS to LBA and wrote down the geometry.
    Since i was planning on swapping out a 10/100 for a gigabit (Realtek 8110cs)
    I decided to upgrade.

    CPU is now Athlon XP 1900
    Memory is now 1GB PC2700
    Hard drive is still 80GB new seagate.

    First of all, during the installation… the format failed.... but unlike before LBA (and entering geometry manually)... it continues... and worked after restart...

    I installed squid.. squidlight...

    tested a download... First download averages 455KB

    went to another PC and downloaded same file... 2.5MB/s BINGO

    sadly the gigabit card did not detect and the test was using a 10/100

    Does anyone know of any cheap gigabit cards that work without drivers? or easy instructions for the 8110cs drivers (which according to forums should work?)

    Anyway... thanks all for helping.

    PS.... I read somewhere that with gigabit... a dual core is recommended... is this needed?

    I would eventually like to replace the current network with all gigabit.

    Thanks...

    PSS... The only two things different were Justin's suggestions and the PC specs... Do either explain why it was not working before... keep in mind I have tried two installations of beta 2, and 3 installations of RC2.



  • hi

    what did you do to get the 2.5 MB/s down, i have squid up and running, i keep getting the same seed on downloads 80 kb/s i even monitored the traffic graph, if i download 2 files, one previously downloaded and a new one from the internet the download speed splits in 2 meaning i getting the previously download file from the internet and not from the cache.

    my squid settings as follows:

    general settings:
    proxy interface: lan
    allow users on interface: checked
    transparent proxy: checked
    do not proxy private …: checked
    enabled logging: checked

    cache management:
    hard disk cache size: 50,000
    memory cache size: 512 (my physical memory is 1 gig)
    minimum object size: 0
    maximum object size: 40000
    memory replacement policy: Heap GDSF
    cache replacement: Heap LFUDA
    enable offline mode: checked

    help really appreciated

    hadi57


Log in to reply