How to enable SFTP access



  • I'm trying to get SFTP access to my home pfsense box (please spare me the lecture about enabling extra services on a firewall :)

    SSH is enabled under System > Advanced

    I have created a new user via System > User manager, then changed /etc/nologin to /bin/sh in /etc/passwd.

    If try and ssh in as this user, the putty window closes or exits after entering the password, winscp client reports packet too large. As a test I can SFTP ok if I used the root account and the 'admin' password.

    So I cant see what is different? Ideas?



  • @Lonney:

    I have created a new user via System > User manager, then …

    just save the newly created user, and open it up again for editing.
    You'll find a new option: "Effective Privileges" - add "User - System - Shell account access" and save.

    Now this new user has SSH ans SFTP access (I tested both).

    No need to edit /etc/passwd manually.