PfSense 2.1 / 2.0 on Dell R610 - Hangs during boot



  • Hi Guys,

    We are provisioning some new production boxes, they are Dell R610s with no additional NICs (4 onboard), H200 with 2 x SAS in RAID 1.

    I have mounted the ISO, and it starts to book up until:

    atrtc0: <at realtime="" clock="">port 0x70-0x7f irq 8 on acpi0

    Where it just hangs, and hangs and hangs.

    I have tried, upgrading the BIOS, enabling VT and disabling the NICs with no luck, still just changes on this screen before I even have a chance to install to disk.

    I have search around, but it seems like a more uncommon problem. Has anyone came across this? Any recommendation?

    </at>



  • I have tried both 2.1 and 2.0, and I have just tried 2.1 32-bit, all produce the same error.

    Any ideas before I have to resort to new hardware or ESX?


  • Netgate Administrator

    A common work around for similar boxes seems to be to disable all the virtualization enhancement options and the multicore CPU in the BIOS during the install. You can re-enable it afterwards.

    Steve

    Edit: re-reading some posts it could be: enable VT, disable multicore/SMP.



  • Hi Steve,

    VT is now enabled, and I have only enabled a single core, still the same thing with normal boot,

    With ACPI disabled in the pfsense boot options, I get to:

    cd0: cd present [47302 x 2048 bytes records]

    Where it hangs, when I hit enter:

    panic: Root mount failed, startup aborted.
    cpuid=0
    KDB: enter: panic



  • We booted the server using an actual CD, same result. I then booted it with pfSense 1.2.3 ISO, which loaded fine, but of course couldn't find the drivers for the PERC H200.

    I am trying a USB boot now to see if that changes anything. Fingers crossed.

    Does anyone else have any ideas?



  • USB fails at same stage, and just tried a R710 with different hardware an a PERC6/i and exactly the same.

    Tried removing the H200 from the R610 and booting, same result.

    I really want to avoid installing ESX, does anyone have any other ideas?