[solved for q1] Change default nanobsd option to 3



  • 1] I configured pfsense 2.1-release x64  vga
    with an ethernet usb, and a usb sandisk cruzer minifit, and the system boots up fine.

    Now, I no longer need the ethernet usb, so I removed it.
    The next boot, pfsense starts to boot but gives me a ROOT mount error.

    I have to select option 3 to boot from usb now, but if I reboot or the system kernel panics when I'm away, it will try to reboot on the wrong mount. How can I make it always select option 3 instead?

    This also happens if you just change which usb controller you have your usb plugged into.
    –-----------------------

    2] Unrelated, but on the automatic install for 2.1, this happened on the daily builds for 2.1 and the release but was not present in 2.0.3

    Is that when you do the automatic interfaces for nanobsd (like when it says to plug in WAN interface), it correctly says which interface you plugged them into. However, after it finishes installing, it changes WAN to usbus0 or something random. My opt2 interface was also messed up, but OPT1 was correctly set.

    Luckily the LAN interface also got set correctly, so I can just login to the router and change the interfaces from the webgui and that fixes it. But I have to remember which interface it told me it detected on the install.
    This issue was not present in 2.0.3 nanobsd, this is a clean install of 2.1

    EDIT: oops, the solution is here for 1]

    http://forum.pfsense.org/index.php/topic,32017.15.html

    /boot/loader.conf should probably be empty.

    And if you want to mimic option 3 exactly, /boot/loader.conf.local should only contain:
    Code: [Select]

    hw.mca.enabled=0
    hw.bce.tso_enable=0
    kern.cam.boot_delay=10000

    Nothing else.

    for me since I am using nanobsd, I had to unlock the file system

    
    /etc/rc.conf_mount_rw
    and
    /etc/rc.conf_mount_ro
    

    2nd problem still remains, but it isn't a huge deal breaker.