PPPoE won't reconnect - 2.1-Release.



  • Howdy ppl,

    So today our ISP went down for about 20 minutes and pfSense would not reconnect the pppoe interface (WAN - bge2 - broadcom 5722). After examining the logs I get:

    Dec 13 10:10:38    ppp: [wan_pppoe0] Link: reconnection attempt xx
    Dec 13 10:10:34    ppp: [wan_pppoe0] Link: reconnection attempt xx in 4 seconds
    Dec 13 10:10:34    ppp: [wan_pppoe0] LCP: Down event
    Dec 13 10:10:34    ppp: [wan_pppoe0] Link: DOWN event
    Dec 13 10:10:34    ppp: [wan_pppoe0] PPPoE connection timeout after 9 seconds
    Dec 13 10:10:25    ppp: [wan_pppoe0] PPPoE: Connecting to ''
    Dec 13 10:10:25    ppp: [wan_pppoe0] Link: reconnection attempt xx
    Dec 13 10:10:24    ppp: [wan_pppoe0] Link: reconnection attempt xx in 1 seconds

    BTW, I could pppoe to the modem with no issues using a notebook.

    pfSense would show the interface as UP, with no IP address assigned to it. If I click "disconnect" on the wan interface, it would show as "disabled". and If I click on "connect" even with no cable attached it would show as UP, with some cached DNS servers, but with no IP. Reeboting didn't change the behavior.

    After trying a bunch of different things - changing the interface type to static then changing back to pppoe, deleting the only ppp virtual nic, rebooting  (not in that order), it started working again without reason. Nevertheless the OpenVPN service would not come back to the Wan interface on the failover group, still using the (slow) backup link.

    Any suggestions? I really want this to be stable….



  • bumping this thread i have the same issue? is there any particular method to get it working ? Thanks



  • The failback of OpenVPN to the primary should be fixed by: https://github.com/pfsense/pfsense/commit/4bf23d320bc96eeabf2daf9024583f2cc5a6662a
    and there have been some changes in 2.1.1 that people reported have made PPPoE reconnect: https://redmine.pfsense.org/issues/1943
    If you have an install where you can upgrade to 2.1.1-prerelease then that should help a lot.