1:1 NAT Issues



  • Ok WAN IP: 24.X.X.226 / 29
    Gateway NONE, i ahve tried 24.x.x.225

    everything work fine

    so my usable range is 226-230

    i got to 1:1 NAT. Add entry…..
    External subnet IP = 24.x.x.230
    Internal IP: 10.20.30.100

    everything else default.

    This works fine. NO Virtual IP's no Firewall rules.
    I also tried the External subnet IP 24.x.x.228 and 24.x.x.229.

    all is fine.

    But if i change it to 24.x.x.227

    my comp (10.20.30.100) loses internet connectivity.

    What Is Going on?

    Iam i setting this up correctly, Why does it work on IP 24.x.x.228-230 but not 227?

    I also have another single IP address, which i tried 1:1 NAT, it works fine.



  • anyone?


  • LAYER 8 Global Moderator

    Well if they are using /30 vs /29

    .227 would be the broadcast on /30 from the .224/30 your on.

    so .225 is the gateway your using?  This seems a bit ambiguous "Gateway NONE, i ahve tried 24.x.x.225"  How would it work if you did not have a gateway set??  So clearly that statement of NONE as a gateway can not be correct.

    So if there is a network mismatch where your using /29 and the gateway has /30 you could work until you get to .227 which would be the broadcast address of your current /30

    You say 228 and 229 work which would be the next /30?????  But .228 is the wire on that /30??  Hmmm – also possible someone else is just stepping on .227?



  • well i said if i change gateway to none, it works for some reason. but here is the screenshot with it selected as it should be.

    [EDIT]

    SO 228 229 230 also work. but 227 does not work. for some reason.

    its a small test network, so there is no one else one it, except for my PE2950, my build freenas box, this pfsense box, and one PC



  • LAYER 8 Global Moderator

    So your internal to some lab?  The only way it would work with no gateway set off the top of my head would be proxy arp
    http://www.cisco.com/en/US/tech/tk648/tk361/technologies_tech_note09186a0080094adb.shtml

    If your sure your masks are setup correctly on both the gateway pfsense is connecting too, etc..  I would think something is stepping on it.  Or something wrong on the device your natting too.



  • I have two sets of IP, first one is just one pack of static and the second of is 5 pack of static.

    SO i set up using only my one pack.  my WAN IP as X.X.32.58 / 30 with gateway of X.X.32.57. works fine.

    i went to VIP, sent up IP Alias X.X.222.226 /29

    now when i setup NAT1:1 everything works fine. i can set up IP ranges from 226-230…...

    Now going back to my original problem.

    for the the single IP the X.X.32.58. I changed the WAN to X.X.222.226 /29 with a gateway of X.X.222.225, works fine, I DELETE VIP. i got to 1:1 NAT setup X.X.225.228, works fine, X.X.225.229 works fine, X.X.225.230 works fine. but still when i do X.X.225.227, my computer loses access to the internet. local works,

    This is the problem i am having. why am i losing one STATIC IP?

    More INFO.

    Changed the WAN IP to  X.X.222.230 /29 with a gateway of X.X.222.225, now when i setup 1:1 NAT  X.X.225.226, X.X.225.227, X.X.225.229,  everything works fine...

    Does anyone think this is a BUG, when i setup WAN to be the first IP of the pack 226, i lose 227, but 228, 229,230 works. if i setup WAN to be 230, i can use 226,227,228,229. basically everything.


Log in to reply