Problemas com NAT + FailOver + Dyndns + Gateway Default



  • Boa Tarde a todos.

    Gostaria de uma luz do pessoal aqui do forum.

    Meu cenário é basicamente o da imagem:.

    FailOver funcionando perfeitamente. DynDNS atualizando corretamente o IP. Squid com FailOver funcionando perfeitamente. O problema é que o NAT que entra pela interface do ADSL não abre o meu TS. Se eu escolher em: System –> Routing -- Interface ADSL como Defautl o NAT funciona perfeitamente pelo ADSL e para o da Embratel. OU seja, meu NAT só funciona com o link escolhido como default.

    Tentei retirar ou deixar de escolher um link default para meus links e meu pfSense insiste em deixar marcado pelo menos um deles

    Se algum colega já passou por isso ou tenha a possível solução, agradeceria muito pela ajuda.

    Agradeço a ajuda.

    ATT

    Breno Alencar



  • Desculpa Breno por não achar uma solução para seu problema. Estava rodando pelo fórum em busca de um probleminha e, de repente, você pode me ajudar.

    Estou implantando failover entre dois links e uso de proxy squid. Acontece que quando um link cai, o secundário entra, mas quem está usando proxy não navega pelo secundário. Como você falou que seu squid com failover está funcionando. Poderia me dizer como você fez? Acredito que isso vá ajudar muitos no fórum.



  • @breno.uni:

    O problema é que o NAT que entra pela interface do ADSL não abre o meu TS. Se eu escolher em: System –> Routing -- Interface ADSL como Defautl o NAT funciona perfeitamente pelo ADSL e para o da Embratel. OU seja, meu NAT só funciona com o link escolhido como default.

    Caro Breno,

    geralmente isso ocorre quando voce desabilitar o replay-to (responsavel de marcar o pacote com o gateway de origem da interface). Caminho dessa configuração é "System > Advanced > Firewall and NAT > Firewall Advanced > Disable reply-to" (deve permanecer desabilitada).

    Se a opção estiver desabilitada, navegue até "Interfaces > ADSL > Static IPv4 configuration > IPv4 Upstream Gateway" e verifique se o gateway está definido.

    Creio que o comando abaixo vai mostrar os pacotes saindo pela interface (dyndns) com o IP da interface ADSL durante uma tentativa de acesso via RDP na interface ADSL.

    tcpdump -ni inter_dyndns port 3389 and src ip_int_adsl
    

    Verique essas configurações e post aqui.

    att,

    Bruno Pinheiro



  • @Bruno:

    @breno.uni:

    O problema é que o NAT que entra pela interface do ADSL não abre o meu TS. Se eu escolher em: System –> Routing -- Interface ADSL como Defautl o NAT funciona perfeitamente pelo ADSL e para o da Embratel. OU seja, meu NAT só funciona com o link escolhido como default.

    Caro Breno,

    geralmente isso ocorre quando voce desabilitar o replay-to (responsavel de marcar o pacote com o gateway de origem da interface). Caminho dessa configuração é "System > Advanced > Firewall and NAT > Firewall Advanced > Disable reply-to" (deve permanecer desabilitada).

    Se a opção estiver desabilitada, navegue até "Interfaces > ADSL > Static IPv4 configuration > IPv4 Upstream Gateway" e verifique se o gateway está definido.

    Creio que o comando abaixo vai mostrar os pacotes saindo pela interface (dyndns) com o IP da interface ADSL durante uma tentativa de acesso via RDP na interface ADSL.

    tcpdump -ni inter_dyndns port 3389 and src ip_int_adsl
    

    Verique essas configurações e post aqui.

    att,

    Bruno Pinheiro

    Não resolveu :(