[SOLVED] NUT 2.0.5_1 package on pfsense 1.2-RC2 not installing



  • I am having the same problem as thread "Nut package gone?" (http://forum.pfsense.org/index.php/topic,4019.0.html), but now it's with the NUT 2.0.5_1 package. I can install other packages, but nut fails with the message "Checking for successful package installation… failed!" The system log only states that it is beginning installation but no error message appears. Just like in the previous thread I found a 0 byte file in /tmp called 'apkg_nut-2.0.5_1.tbz'. I'm not sure pfSense is looking in the right place to download this file. Yesterday I upgraded to 1.2-RC2 and today I did a fresh LiveCD install but this issue still exists. Anyone else having this issue? Thanks in advance for the help!

    chartek



  • Installed pfSense 1.2-RC3 and still the same result.

    I noticed that pkg_config.xml from http://www.pfsense.com/packages/ is trying to download the url ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6-stable/All/nut-2.0.5_1.tbz, but that file doesn't exist (although I do see nut-2.2.0.tbz).



  • Yep…

    Update to the nut 2.2.0 version (current FreeBSD 6 stable version) :

    Change the pkg_config.xml to use the nut 2.2.0 version

    <package><name>nut</name>
      <descr>Network UPS Tools</descr>
      <website>http://www.networkupstools.org/</website>
      <category>Network Management</category>
      <version>2.2.0</version>
      <status>BETA</status>
      <required_version>1.0</required_version>
      <maintainer>rswagoner@gmail.com</maintainer>
      <config_file>http://www.pfsense.com/packages/config/nut/nut.xml</config_file>
      <configurationfile>nut.xml</configurationfile>
      <depends_on_package_base_url>ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-6-stable/All/</depends_on_package_base_url>
      <depends_on_package>nut-2.2.0.tbz</depends_on_package></package>

    Change http://www.pfsense.com/packages/config/nut/nut.xml

    <description>Describe your package here</description>
        <requirements>Describe your package requirements here</requirements>
        <faq>Currently there are no FAQ items provided.</faq>
    <name>nut</name>
    <version>2.2.0</version>
    <title>Services: NUT</title>
    <savetext>Change</savetext>
    <aftersaveredirect>/status_nut.php</aftersaveredirect>
    <include_file>/usr/local/pkg/nut.inc</include_file>
        …..

    <fielddescr><strong>Local UPS Model</strong></fielddescr>
    <fieldname>driver</fieldname>
    <description>If generic or cable specified in parenthesis you need
    to select the appropriate option below.</description>
    <type>select</type>
    <options><option><name>APC Back-UPS (Generic)</name>
    <value>genericups00</value></option>
    <option><name>APC Back-UPS RS (Generic)</name>
    <value>genericups01</value></option>
    <option><name>APC Back-UPS Pro (Cable)</name>
    <value>apcsmart00</value></option>
    <option><name>APC Smart-UPS (Cable)</name>
    <value>apcsmart01</value></option>
    <option><name>APC Matrix-UPS</name>
    <value>apcsmart02</value></option>
    <option><name>APC Masterswitch (Generic)</name>
    <value>genericups02</value></option>
    <option><name>APC Back-UPS USB</name>
    <value>usbhid-ups00</value></option>
    <option><name>APC Back-UPS LS USB</name>
    <value>usbhid-ups01</value></option>
    …....

    etc, etc... (replace all "newhidups" by the new driver "usbhid-ups")

    or still use the old stable one :

    Put the files nut-2.0.5_1.tbz and nut-usb-2.0.5_1.tbz on the http://www.pfsense.com/packages/All/ directory

    Change the pkg_config.xml to use the old version

    <package><name>nut</name>
      <descr>Network UPS Tools</descr>
      <website>http://www.networkupstools.org/</website>
      <category>Network Management</category>
      <version>2.0.5</version>
      <status>BETA</status>
      <required_version>1.0</required_version>
      <maintainer>rswagoner@gmail.com</maintainer>
      <config_file>http://www.pfsense.com/packages/config/nut/nut.xml</config_file>
      <configurationfile>nut.xml</configurationfile>
      <depends_on_package_base_url>http://www.pfsense.com/packages/All/</depends_on_package_base_url>
      <depends_on_package>nut-2.0.5_1.tbz</depends_on_package>
      <depends_on_package>nut-usb-2.0.5_1.tbz</depends_on_package></package>

    My opinion :

    As the version 2.2.0 is used as common one for the FreeBSD 6, it will be fine to use it.
    The old 2.0.5 version is a little bit hard to find now.

    Expecting it help.

    Regards,</options>





  • @Surf@ceS:

    Reported Ticket :

    http://cvstrac.pfsense.com/tktview?tn=1518,33

    I didn't see this post until now. I will bump the version to 2.2.0 in a few minutes. I assuming you will test this out and report back any issues.



  • Perfect! The new package showed up in the list, downloaded, installed, and I have it up and running without any problems. Thank you! :)

    chartek


Log in to reply