Load Balancer na mesma LAN



  • E ae pessoal, meu primeiro post aqui, to com um problema grande, tenho 2 servidores na mesma LAN que não saem para WAN, os usuários fazem acesso via browser como uma intranet, e eu preciso balancear esses dois servidores, fiz essas configurações

    LAN = 10.1.55.x/24
    IP pfsense = 10.1.55.100
    Server 1 = 10.1.55.110
    Server 2 = 10.1.55.111

    Fui em Services > Load balancer e configurei:

    • Pools
      Servers - loadbalance - 10.1.55.110 10.1.55.110 - 8443 HTTPs

    • Virtual Servers
      VirtualServer    tcp    10.1.55.200    8443

    Só que ele so me redireciona para a pagina do pfsense.

    O que eu faço?



  • Alguém pode me ajudar? Tentei configurar outbound mas não foi



  • Olá!

    Acabei de ver a mensagem que você me mandou. Então já criou o tópico, ótimo.

    Primeiro você precisa entender que este fórum é formado por pessoas que colaboram de forma voluntária e muitas vezes não te responderão de pronto. Todos temos responsabilidades e compromissos para atender. Tenha paciência.

    Sobre sua necessidade, acredito que este tópico seja o que você procura: http://forum.pfsense.org/index.php?topic=47126.0

    Adapte essa solução para a sua rede.

    EDIT: Sempre faça uma pesquisa no Fórum antes de criar um novo tópico, alguém pode já ter resolvido o problema antes.



  • Eu já deu uma olhada e já fiz algumas coisas… Tudo está na mesma rede lan, os dois servers e o pfsense, como descrevi.

    Criei um alias indo em Firewall > Alias
    Mudei a porta do pfsense para 8082 para não haver conflito

    Mas essa parte eu não entendi

    "Com relação a interface de publicação, eu prefiro publicar o ip virtual na interface onde os clientes estão ou de onde eles vem."

    Mas já fiz quase de tudo



  • Em que ponto você está?

    @marcelloc:

    Para você conseguir fazer esse balanceamento interno funcionar, você vai precisar forçar um nat de saída no pfsense para que as solicitações feitas ao ip do balanceamento sejam respondidas para o firewall e não o ip interno do cliente que solicitou.

    Exemplo de seqüência de pacotes sem forçar o source nat:

    • 10.10.0.51 pede a pagina para 10.0.0.121

    • 10.0.0.121 encaminha para 10.0.0.21

    • 10.0.0.21 verifica que 10.0.0.51 esta na mesma rede

    • 10.0.0.21 responde a solicitação direto para 10.0.0.51

    • 10.0.0.51 rejeita a comunicação porque pediu o site para 10.0.0.121 e não para 10.0.0.21

    Quatro pontos importantes:

    • 10.0.0.121 precisa ser um alias no pfsense para ele poder responder as requisições

    • Não esqueça de deixar uma regra na lan permitindo o acesso ao ip virtual e provavelmente aos servidores web

    • Você precisa mudar a porta da interface web de 80 para não dar conflito com a porta do loadbalance

    • Fazendo o source nat você só terá registrado o ip do firewall no log dos servidores web.

    Outro tópico recente com a mesma temática.
    http://forum.pfsense.org/index.php/topic,69329.msg379074.html#msg379074



  • 10.1.5.150 criei um alias no pfsense
    Criei uma regra permitindo tudo
    E troquei a porta do pfsense para 8082



  • @João.Lara:

    10.1.5.150 criei um alias no pfsense

    OK

    @João.Lara:

    Criei uma regra permitindo tudo

    Não precisa

    @João.Lara:

    E troquei a porta do pfsense para 8082

    OK

    E o resto da configuração, principalmente o source nat? ???



  • So não fiz essa configuração, eu não sei faze-la  :-[



  • @João.Lara:

    So não fiz essa configuração, eu não sei faze-la  :-[
    [/quote]

    Este é o ponto que só resolve pesquisando e estudando.

    Fonte principal:
    http://bit.ly/1aBN9ZM

    Fontes a partir da fonte principal(com menos de 5 segundos de pesquisa):
    http://forum.pfsense.org/index.php?topic=45771.0
    http://www.packtpub.com/article/pfsense-configuring-nat-firewall-rules
    http://www.fug.com.br/historico/html/freebsd/2009-08/msg00622.html

    Ter pressa mas não ter conhecimento ou paciência é um problema bem complicado.



  • Mas isso serio o mesmo de configurar o outbound nat? E tirar do automatico colocando no manual também?



  • Ele está me redirecionando para a pagina de Login do PfSense



  • Eu acho que é um pequeno problema, quando eu mudo a porta do pfsense se eu reinicio ele não consigo mais acessar então voltei para a porta padrão, isso pode ser conflito na porta certo? Por que o virtual server funcionou, so que ao inves de ir para minha pagina ele vai para o pfsense



  • Alguem sabe o que posso fazer?



  • Eu já tentei mexer no outband nat, trocar a porta do pfsense mas nada acontece. To precisando configurar o quanto antes, sabe onde posso arrumar marcelo?



  • João Lara,

    Tenha calma, você está nos perguntando mas você não tem pesquisado sobre isso aqui no Fórum, tem centenas de tópicos falando sobre a troca da porta do PFSense, e outras centenas falando sobre Outbound NAT.

    Sobre a porta do PFSense:
    Escolha uma porta, 222 por exemplo, depois ajuste ou até crie regras de Firewall que permitam o acesso ao Lan Address por essa porta. Feito isso, ai sim você altera a porta no PFSense, pelo Advanced.

    Depois você cria as regras de Outbound NAT.



  • Mas segui os tutorias de outbound, so que meu servidor virtual está me redirecionando para o pfsense e não para minha pagina web, por isso estou falando aqui, por que tentei e não consegui



  • @João.Lara:

    Mas segui os tutorias de outbound, so que meu servidor virtual está me redirecionando para o pfsense e não para minha pagina web, por isso estou falando aqui, por que tentei e não consegui

    O PFSense está na porta padrão?(80)?

    Se estiver, precisa trocar a porta, seguindo o que eu falei e depois vá em System>Advanced, marque a opção " Disable webConfigurator redirect rule". Lembre de DEIXAR DESMARCADO a opção " Disable webConfigurator anti-lockout rule " ou você perderá o acesso a interface.



  • O servidor virtual agora nem me redireciona para o pfsense, depois de mudar a porta.

    Criei uma regra na aba outbound do Nat, da seguinte forma:

    Interface -> escolhi a interface de saida do pacote
    source -> any para internet ou outra rede interna com mascara
    Destination -> ip do servidor web
    Destination port -> 80
    Nat address -> ip virtual criado

    Com este Nat, faço todo pacote que estiver saindo do firewall para o servidor
    web de destino, sai com o ip que escolhi.

    E como te falei, segui os tutorias, entendi como funciona o outbound, mas ele não vai como preciso e como ele tem que ir! Por isso estou precisando de ajuda



  • Meu outbound nat não fica com o ip que eu configurei, ele sempre fica com o final .0

    E para acessar minha pagina web eu tenho que ir no ip https://10.211.55.43:8843 mas meu servidor virtual não me redireciona, tenter configurar aliases mas também não deu.

    ![Captura de Tela 2013-11-22 às 18.44.45.png](/public/imported_attachments/1/Captura de Tela 2013-11-22 às 18.44.45.png)
    ![Captura de Tela 2013-11-22 às 18.44.45.png_thumb](/public/imported_attachments/1/Captura de Tela 2013-11-22 às 18.44.45.png_thumb)



  • @João.Lara:

    Meu outbound nat não fica com o ip que eu configurei, ele sempre fica com o final .0

    E para acessar minha pagina web eu tenho que ir no ip https://10.211.55.43:8843 mas meu servidor virtual não me redireciona, tenter configurar aliases mas também não deu.

    NAT Port 8843 não 80