Desabilitar cache Squid



  • Olá pessoal, estou colocando "0" nos campos:

    • Hard disk cache size
    • Memory cache size
    • Minimum object size
    • Maximum object size

    Com intenção de desabilitar o Cache do Squid. Parece que não ta desabilitando pois a internet ta uma carroça.

    O host é um Intel(R) Core(TM)2 Duo CPU E7500 @ 2.93GHz 4GB de Ram. Mesmo com as configurações baixíssimas o squid esta deixando a conexão lenta.

    To achando que é aquele negocio la do Softupdate. pode ser?



  • @Antonio:

    Olá pessoal, estou colocando "0" nos campos:

    • Hard disk cache size
    • Memory cache size
    • Minimum object size
    • Maximum object size

    Com intenção de desabilitar o Cache do Squid. Parece que não ta desabilitando pois a internet ta uma carroça.

    O host é um Intel(R) Core(TM)2 Duo CPU E7500 @ 2.93GHz 4GB de Ram. Mesmo com as configurações baixíssimas o squid esta deixando a conexão lenta.

    To achando que é aquele negocio la do Softupdate. pode ser?

    Para desabilitar o cache do Squid, é preciso ir no Squid, depois em na aba Local Cache, mude a opção "Hard disk cache system" para "Null".



  • Ótimo, consegui, a conexão voltou ao normal. Mas preciso do cache rodando e sem esta lentidão. Se alguém puder me dar uma luz. Por enquanto vou estudando os tutoriais.



  • Esta com o softupdate habilitado na partição que esta o cache do squid?
    Esta utilizando qual versão do squid?
    Esta utilizando havp?
    Qual e o numero de conexões simultaneas?
    Nós dê mais detalhes sobre seu ambiente.



  • Esta com o softupdate habilitado na partição que esta o cache do squid?

    R: Não

    Esta utilizando qual versão do squid?

    R: 2.7.9 pkg v.4.3.3

    Esta utilizando havp?

    R: Não.

    Qual e o numero de conexões simultâneas?

    R: + ou - 100

    Ps.: Atualmente desabilitei o cache porquê a lentidão estava fora do sério. Só reabilitarei se descobrir como melhorar a performance. Meu pfSense é 2.1 amd64.



  • Amigo, sinto muito, mas você está na mesma situação que eu e o colega Gilmarcabral.

    Leia este tópico: http://forum.pfsense.org/index.php/topic,68118.msg372646.html#msg372646



  • Esta utilizando o pfsense 2.1?
    Caso sim tente utilizar esta versão do squid.
    3.1.20 pkg 2.0.6



  • Sim. Instalei hoje o Squid3 e de cara ja deu a mesma lentidão. Falei com um amigo meu e vou instalar o squid em um host dedicado. Da mais trabalho mas depois de bem configurado nem se compara. obrigado.



  • @Antonio:

    Sim. Instalei hoje o Squid3 e de cara ja deu a mesma lentidão. Falei com um amigo meu e vou instalar o squid em um host dedicado. Da mais trabalho mas depois de bem configurado nem se compara. obrigado.

    Cuidado com essas indicações de amigos… já postei no seu outro tópico a respeito disso, leia lá.



  • Estou usando o Pfsense a  semanas e na 2ª semana tive o mesmo problema que você.
    Limpei o cache e alguns dias novamente a conexão voltou a ficar lenta
    Desabilitei o cache e hoje novamente o mesmo problema.

    Notei que o único site que navega tranquilo é o Google, mas meu squid não tem regras

    A unica solução até o momento foi reiniciar o Server, pois apenas reiniciando o Squid não funcionou.

    Alguém sabe o que possa estar acontecendo?



  • O grande ponto a corrigir é habilitar o softupdate na participação de log e cache.

    Você pode fazer isso, reinstalando, dando boot com o live cd ou instalando um segundo disco.

    Os procedimentos de melhora de performance de disco estão nos tutoriais.