[Resolvido] Problema de Certificado Squid3-Dev + Squidguard3



  • Ola.
    Estou tendo problemas na configuração do meu squid3-dev. Estou usando o Proxy SSL Transparente. Gerei o CA do tipo internal CA e exportei no formato .CRT. Instalei no repositório de confiança do IE e ainda assim fica o tempo todo pedindo para exibir conteúdo bloqueado. Mas após clicar várias vezes em exibir conteudo, ele acaba carregando com muito custo a pagina. No Firefox e no Chrome, algumas paginas nem chegam a carregar por completo ficando apenas com sujeira no navegador. No IE, qnd eu entro no Facebook, por exemplo, vai carregando a pagina aos poucos conforme eu vou clicando em exibir conteúdo bloqueado.
    No PFSense, Na aba Certificates do Cert Manager, tentei gerar certificado dos tres tipos: user, server e certificate authority. Importei para repositórios de confiança do IE e o problema persiste. Tentei exportar inclusive em outros formatos como P12.
    Lendo alguns posts aqui no forum, tentei usar o campo Bypass proxy for these destination IPs, listei os ips q não deveriam dar o problema e ainda assim o problema persistiu. Criei uma acl no squidguard e digitei tanto nome de domínio quanto os ips dos sites e os marquei como whitelist.

    Esse ultimo passo foi por desencargo de consciencia, pois não criei nenhuma regra de restrição a nada ainda. somente liberei a default access como allow em common acl… mesmo estando tudo liberado o problema persiste.

    Alguem conseguiu driblar esse problema ou eu q to fazendo uma caca gigante aqui? rsrsrs
    Se alguem puder me ajudar eu agradeço. Vai me poupar uma gama gigante de cabelos brancos...rsrs
    Muito obrigado.



  • O certificado é do tipo CA e precisa ser importado como CA confiável. Não deixe na importação automática do IE.

    No firefox, você precisa importar a CA dentro do aplicativo, ele não lê ou usa a estrutura de certificados do Ie como o chrome faz.

    Para ter certeza que está ok, desabilite o squidguard e teste o proxy transparente/não transparente de ssl.



  • Muito obrigado pela força. Só hoje tive tempo de trabalhar com o servidor novamente. Deu tudo certo. Valeu mesmo.
    Como faço para editar o post e marcar como resolvido?