CARP- VIP-Loadbalancer-Outboud NAT.



  • Im having difficulty getting an Out bound NAT to work correctly with a CARP VIP.  What I have is a VIP assigned to a Load Balancer that is in front of two servers. what I need is for both Servers to LEAVE the pfSense using the VIP as its outbound NAT.  To make this even more difficult I have 1:1 NAT that is enabled for EACH server to facilitate monitoring.  When I try to set up the Out bound NAT the 1:1 NAT takes precedence.  How can I get the out bound NAT rule to be the one used and not the 1:1 NAT address.

    X.X.7.38  (VIP on Public Side)
                          |
                          |
                  +–--+------------------+
                  |                              |
      192.168.12.30                192.168.12.31

    I have set under Advance settings the check mark for:
      "Disables the automatic creation of additional NAT 1:1 mappings for access to 1:1 mappings of your external IP addresses from within your internal networks. Note: Reflection for 1:1 NAT might not fully work in certain complex routing scenarios."

    and Unselected the:
      "Automatically create outbound NAT rules which assist inbound NAT rules that direct traffic back out to the same subnet it originated from. "