2.0.1 to 2.1 upgrade: Register DHCP leases in DNS forwarder no longer works



  • Upgraded from 2.0.1-RELEASE to 2.1-RELEASE

    Register DHCP leases in DNS forwarder option was enabled
    and working in 2.0.1.

    Now, every time a lease is added or renewed, the registration
    fails with a log "Unable to add forward map from <name>to <ip>: REFUSED"

    Tried disabling and then re-enabling the option, problem persists.

    Before I dig deeper into the configuration, I was wondering whether
    this is a know issue and whether there is a fix?</ip></name>



  • After further investigation, I am somewhat confused as to the
    path that DNS forwarder updates are expected to take.

    The logs I mentioned above are from dhcpd, which implies that
    updates happen from dhcpd -> dnsmasq. But I see that
    dhcpleases is also running, which implies that route.

    When a new lease is granted, I see that the leases file is
    updated, but the hosts file is not. If I restart dhcpleases
    then the hosts file is updated.

    I also see these messages in system.log: "dhcpleases: Could not
    deliver signal HUP to process because its pidfile does not exist, No
    such file or directory."

    But the dnsmasq.pid file passed on the dhcpleases command
    line is correct and the PID it contains is also valid (corresponds
    to dnsmasq's PID).

    MV



  • Did you ever get to the bottom of this? I am getting the same error message in dhcpd.log (unable to add forward map REFUSED) and DHCP leases aren't getting registered in DNS.

    EDIT: Looks like I had some DHCP reservations on an old unused interface that were conflicting. I removed the reservations, restarted the DHCP service, then new leases seemed to get their reverse maps properly added. To force update all the existing leases I un-checked "Register DHCP leases in DNS forwarder" under DNS Forwarded, applied, then re-checked it and all my leases showed up.

    My apologies for the necro-post, but I couldn't find hardly any info on this issue except this thread. Hopefully this will help someone else. :)


Log in to reply