12 second delay on some but not all web connections.



  • This is a really weird one.  We're seeing intermittent 12 second (and it's always 12) delays on opening tcp connection to some hosts.  It's like the initial syn or ack packets are getting lost then retrying.  We're running 2.1 embedded on a headless Celeron based system  with one lan and three wans (webpass 200mbit, comcast biz 70mbit and sonic dsl 25mbit).  We've tried forcing one wan and it still happens on all of them so we think it's local.  It doesn't seem to be load related, we can reproduce it on http and ssh connections, it happens at the tcp level before the protocol establishes, and doesn't impact open connections and we're completely stumped.  Does anybody have thoughts on where to look next?



  • Same boat here, intermittent web page loading on 2.1 single WAN cox cable here.

    I thought it was dns timing out at first, but doesn't matter if we are using dnsmasq, or direct to pubic dns servers.

    The clearest way I can describe it from a users perspective, is the browser shows 'connecting' for 10-12 seconds before either loading the page or timing out.  It happens once every 10 loads maybe.  Switching back to another router solves the problem, but I'd prefer to use pfsense.

    I've tried the df bit option, enabling disabling dnsmasq, enabling wan side ping, turning off checksome offloading, I can't figure it out.  I'm about to try out monowall and see if the same thing happens.

    Hardware wise I'm on: http://www.newegg.com/Product/Product.aspx?Item=N82E16816101364


Log in to reply