Load Balancer showing wrong Status when using Alias's for the port



  • Hello,

    I have come across the issue of using Load Balancer with Port Alias's and the status not showing properly in the GUI. I have submitted a bug report (https://redmine.pfsense.org/issues/3330 ) but wanted to see if anyone else has experienced this issue.

    Checking using relayctl show summary shows the pool as being active with all 3 hosts.

    I have tested changing the name of the Alias to not include (_) underscores, but it does not work either (previous bug was using a (.) period would cause the Unknown - relayd not running? to show in the GUI

    The only way the Status in the GUI would show is if i put in a single port number instead of an Alias.

    I have restarted the relayd several times as well just to be sure.

    ![Firewall Port Alias.JPG](/public/imported_attachments/1/Firewall Port Alias.JPG)
    ![Firewall Port Alias.JPG_thumb](/public/imported_attachments/1/Firewall Port Alias.JPG_thumb)
    ![Load Balance Pool 01.JPG](/public/imported_attachments/1/Load Balance Pool 01.JPG)
    ![Load Balance Pool 01.JPG_thumb](/public/imported_attachments/1/Load Balance Pool 01.JPG_thumb)
    ![Load Balance Pool Status 01.JPG](/public/imported_attachments/1/Load Balance Pool Status 01.JPG)
    ![Load Balance Pool Status 01.JPG_thumb](/public/imported_attachments/1/Load Balance Pool Status 01.JPG_thumb)
    ![Load Balance Pool.JPG](/public/imported_attachments/1/Load Balance Pool.JPG)
    ![Load Balance Pool.JPG_thumb](/public/imported_attachments/1/Load Balance Pool.JPG_thumb)
    ![ralayctl show summary.JPG](/public/imported_attachments/1/ralayctl show summary.JPG)
    ![ralayctl show summary.JPG_thumb](/public/imported_attachments/1/ralayctl show summary.JPG_thumb)
    ![Virtual Servers 01.JPG](/public/imported_attachments/1/Virtual Servers 01.JPG)
    ![Virtual Servers 01.JPG_thumb](/public/imported_attachments/1/Virtual Servers 01.JPG_thumb)
    ![Virtual Servers Status 01.JPG](/public/imported_attachments/1/Virtual Servers Status 01.JPG)
    ![Virtual Servers Status 01.JPG_thumb](/public/imported_attachments/1/Virtual Servers Status 01.JPG_thumb)



  • tried several different names / descriptions and seems anything using an Alias for the ports, gives me this issue.

    Is anyone using Alias's in ports with load balancing?



  • I know this is an old thread, but did you ever get a resolution?

    I just ran into this with 2.1.5-RELEASE (amd64).  I had both IP and Port aliases setup for the Virtual Servers and it would not work until I changed them to numeric entries.  Not a show-stopper but it would be convenient to use aliases in the Load Balancer.  It helps keep things consistent with the Firewall Rules and Outbound NAT setup.

    Thanks.



  • Unfortunately no, and even for me using single Ports the monitor just always shows the balancer as unknown status :(, tried numerous guides and set ups and none of them work for me on my 2.1 box so i just gave up on it.