Install on vps give root mount error



  • Installation:
    Netbooted a system and did a zcat image| dd of=/dev/vda bs=16K
    This went fine, but then it ends with:

    ROOT MOUNT ERROR:
    If you have invalid mount options, reboot, and first try the following from
    the loader prompt:

    set vfs.root.mountfrom.options=rw

    and then remove invalid mount options from /etc/fstab.

    Loader variables:
    vfs.root.mountfrom=ufs:/dev/ufs/pfsense1
    vfs.root.mountfrom.options=ro,sync,noatime

    Manual root filesystem specification:
      <fstype>:<device>  Mount <device>using filesystem <fstype>eg. ufs:/dev/da0s1a
                          eg. cd9660:/dev/acd0
                          This is equivalent to: mount -t cd9660 /dev/acd0 /

    ?                  List valid disk boot devices
      <empty line="">      Abort manual input

    mountroot>?
    List of GEOm managed disk devices:
    iso9660/CDROM acd0t01 acd0
    Then I tried "ufs:/dev/ufs/acd0 ufs/dev/ufs/acd0t01 but I still can find the root device.

    How can I get this working?</empty></fstype></device></device></fstype>



  • @martijn-pf:

    Installation:
    Netbooted a system and did a zcat image| dd of=/dev/vda bs=16K
    This went fine, but then it ends with:

    ROOT MOUNT ERROR:
    If you have invalid mount options, reboot, and first try the following from
    the loader prompt:

    set vfs.root.mountfrom.options=rw

    and then remove invalid mount options from /etc/fstab.

    Loader variables:
    vfs.root.mountfrom=ufs:/dev/ufs/pfsense1
    vfs.root.mountfrom.options=ro,sync,noatime

    Manual root filesystem specification:
      <fstype>:<device>Mount <device>using filesystem <fstype>eg. ufs:/dev/da0s1a
                          eg. cd9660:/dev/acd0
                          This is equivalent to: mount -t cd9660 /dev/acd0 /

    ?                  List valid disk boot devices
      <empty line="">Abort manual input

    mountroot>?
    List of GEOm managed disk devices:
    iso9660/CDROM acd0t01 acd0
    Then I tried "ufs:/dev/ufs/acd0 ufs/dev/ufs/acd0t01 but I still can find the root device.

    instead of ufs:/dev/acd0 try exactly this ufs:/dev/da0s1a. type the highlighted phrase as it is infront of the mountroot>. 
    How can I get this working?</empty></fstype></device></device></fstype>


  • Netgate Administrator

    That's unlikely to work since /dev/da0 is not a listed device.

    You have copied the image to /dev/vda but that is also not a GEOM recognised device.
    The only thing recongnised is a CD-ROM drive. Is that the virtual drive from the hypervisor?

    Steve