HP NC373F Fiber card status No Carrier



  • Hello, all! I have an HP server that I'm trying to get a fiber connection up and running on, and ifconfig reports no carrier. This connection works just fine on a Juniper router with a JXU-1SFP-S card, but will not bring the card up on the HP under pfSense.

    The card is listed under supported hardware, so I don't think it's a compatibility problem.

    Here's the ifconfig -m bce0 output:

    bce0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=c00bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso,linkstate>capabilities=c01bb <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,tso4,vlan_hwtso,linkstate>ether 28:92:4a:2c:26:20
    	inet6 fe80::2a92:4aff:fe2c:2620%bce0 prefixlen 64 scopeid 0x11 
    	inet x.x.x.x netmask 0xfffffffc broadcast x.x.x.x
    	nd6 options=1 <performnud>media: Ethernet autoselect (none)
    	status: no carrier
    	supported media:
    		media autoselect
    		media 1000baseSX mediaopt full-duplex</performnud></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,tso4,vlan_hwtso,linkstate></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,jumbo_mtu,vlan_hwcsum,vlan_hwtso,linkstate></up,broadcast,running,simplex,multicast> 
    

    I've tried forcing the media type with no effect. Also downed and upped the interface, still no change. Do I need to adjust options or flags? Anyone have any hints as to why this card will not bring up the link? I get a green light on the NIC, sometimes it will flash as if there's traffic for a but before it goes solid. I've never see any other status besides "no carrier". My googling has come up dry. Any thoughts are welcome, I'll gladly provide anything useful.

    Thanks!



  • Well, HP is convinced it's a driver issue, though the card is specifically listed on the compatibility page. Is there a way to verify that this model of card has worked under pfSense? Is there a way for me to get updated drivers?

    Thanks!