Unable to communicate with pfsense (packages)



  • When I try to get a list of packages for pfsense I get the error:

    "Unable to communicate with www.pfsense.com. Please verify DNS and interface configuration, and that pfSense has functional Internet connectivity."

    As suggested in other similar posts I tried:

    ```
    fetch -o - http://www.pfsense.org/packages/pkg_config.8.xml

    
    from the command line and while it took a few seconds, it returned an XML file.
    
    Does pfsense have a timeout for retrieving the packages and it's just taking too long to get the XML file?


  • Hi there;
    Do you have the web access to pfsense ?
    Looks like you have a problem with your DNS. Make sure that the connectivity is ok to the router.
    then with your pfsense console setup go to the option 8 (Shell). first type this command "cat /etc/resolve.conf ". Check whether your  DNS IPs are there. If not use the vi editor to edit that file. "vi /etc/resolve.conf".
    ping your DNS and www.google.com to check whether the DNS  works.


  • Netgate Administrator

    If you are able to download the xml file manually you probably don't have a DNS issue. Check that you have a valid update URL selected
    Go to System: Firmware: Updater Settings:
    Choose the appropriate URL (32 or 64 bit) from the drop down and save it.

    Steve



  • @stephenw10:

    If you are able to download the xml file manually you probably don't have a DNS issue. Check that you have a valid update URL selected
    Go to System: Firmware: Updater Settings:
    Choose the appropriate URL (32 or 64 bit) from the drop down and save it.

    Steve

    Selected the "amd64 stable updates" and saved the settings but still getting the same issue.



  • Figured out the issue in the end.  Checked the logs straight after trying to download the list of available package and noticed the following errors:

    php: /pkg_mgr.php: XML_RPC_Client: Connection to RPC server www.pfsense.com:80 failed. Operation timed out 103
    php: /pkg_mgr.php: XMLRPC communication error: Operation timed out
    

    Googling these errors landed me at the following wiki page:

    https://doc.pfsense.org/index.php/Controlling_IPv6_or_IPv4_Preference

    By preferring IP V4 with the following command:

    env ip6addrctl_enable="yes" ip6addrctl_policy="prefer_ipv4" /etc/rc.d/ip6addrctl start
    

    i was able to download and install packages!