Cannot add new interface, help



  • on pfsense 2.1 installed to a harddrive on a pc, my goal is to add a wireless ap on the 3rd nic(opt1) and be on the same network as the wired pc's.
    reading on how to bridge 2 nics(lan + opt1) on a 3 nic system, but on the interface assignment page i do not have the "+" sign to add another interface, all 3 physical nics do show up(wan, lan opt1) but cannot add a new interface to continue to bridge the 2 nics, i was following this guide reply #2 http://forum.pfsense.org/index.php/topic,20917.0.html



  • You first need to create the bridge under the "bridge" tab to be able to assign it.



  • @GruensFroeschli:

    You first need to create the bridge under the "bridge" tab to be able to assign it.

    so i need to create a bridge 1st with lan and opt1, would that create opt2 in the assignment page.
    if yes then reassign opt2 to lan and lan to bridge0.

    if thats the case why dont i have the "+" sign in the assignments page, reading about bridging it seems by looking at users pics that they have it and guides state to just add the extra interface by using the "+" sign b4 adding the bridge



  • I really can't help you, but I thought i'd chime in and say I also don't have the + sign mentioned in documents that tell you to create a new interface.  Though the documents i'm finding that say I need to add an interface are for 2.0 and we're running 2.1.  Not sure if that's why or if we're just missing something.

    I ran into this when adding access to my dsl modem's ip address so I could access the config and status pages  from the LAN.  Aside from the NAT rule, it didn't match the instructions.  I ended up just adding a virtual IP and going that route.  It works.

    My next step is to setup a 3rd interface for my WAP though I don't want to bridge mine.  Good luck.


  • Rebel Alliance Global Moderator

    Is this the plus sign you say is missing?

    I am running
    2.1-RELEASE (i386)
    built on Wed Sep 11 18:16:50 EDT 2013
    FreeBSD 8.3-RELEASE-p11

    If you are not seeing this plus sign, can you post a screen shot showing that its missing?






  • This is my version of pfSense:  2.1-RELEASE  (amd64)  built on Wed Sep 11 18:17:48 EDT 2013

    I attached a screen shot of mine.  Hope it worked and helps.

    Edit:  I checked and I do have the + on the bridge tab though i'm not the one trying to do bridging.



  • Rebel Alliance Global Moderator

    Seems your using the pfsense_ng theme.. I changed to that to test.. And show the + sign

    Sure you don't have something blocking it in your browser?

    Look at the source of the page do you see

    
    	[![add](./themes/pfsense_ng/images/icons/icon_plus.gif "add interface")](interfaces_assign.php?act=add)
    
    

    Maybe there is a typo in the path to the gif?  Are you missing all + signs?  Do you have the file the page points to?




  • I do not seem to have that in the source of the page.  Seems the whole section is missing.

    tried with IE10 and opera 12.16 on 64bit windows 7.

    I have plus signs everywhere else I've needed to use them.

    I just went through all of the default available themes and the + sign is missing under interfaces on all of them.  the pfsense_ng theme was the default one when I installed.  Maybe I should also add my install is only a few days old and I've set this up in esxi 5.5.  Don't see why this would matter though.


  • Rebel Alliance Global Moderator

    No that wouldn't matter - well if the code is missing from the page, would explain why you don't have the button ;)

    As to why that would be missing in the amd64 version and not the i386?  Have no idea?

    There seem to be lots of people that run the amd64 version for really no good reason to be honest.. I also run my pfsense on esxi - and is there some reason you have more than 4GB of ram given to pfsense?  If your not over 4GB of ram, there is no reason to run the 64bit version.



  • currently no reason.  Wanted the headroom for later if need be for any packages I might play way.  though given this, I may wipe it and run the x86 and hope I don't have a need for more RAM.

    Wonder if the issue i'm having with squid guard and ssl cert errors is also related to me running the x64 version.  :-(

    Edit:  At least this is a test install so i'm not losing anything if I start over.


  • Netgate Administrator

    If you have already assigned all the available NICs you won't see a + sign. (As far as I can remember!)

    Steve



  • @johnpoz:

    Seems your using the pfsense_ng theme.. I changed to that to test.. And show the + sign

    Sure you don't have something blocking it in your browser?

    Look at the source of the page do you see

    
    	
    	
    	[![add](./themes/pfsense_ng/images/icons/icon_plus.gif "add interface")](interfaces_assign.php?act=add)
    	
      
    
    

    Maybe there is a typo in the path to the gif?  Are you missing all + signs?  Do you have the file the page points to?

    yes thats the "+" sign im missing in the interface assignment page, its everywhere else but not there, the code for it  is missing as i did hover my mouse over in that section and my mouse did not change from pointer to hand symbol.
    i tried assigning/enabling and disabling the opt1 interface to see if the + sign would show up but thhat didnt work, im on pfsence 2.1  i386 harddrive install.
    i did try the nano install and the + sign was there.
    ive manged to get the opt2 by doing the bridging first of lan and opt1, then on the assignment tab the opt2 interface showed up connected to port as "bridge0", i then changed the lan port to bridge0 and opt2 to the lan ports mac address, this way sucks as u do loose connectivity to the gui and have to from the console reboot and make sure the interfaces are configured properly and then make sure the firewall rules are what theyre supposed to be for the bridged lan.
    it would have been so much easier if the "+" sign was there as all the tutorials and howto posts state that it should, but now that i figured it out it should be easier next time if i add another nic.

    if any1 else had this prob i could write a tut with more details and pics, let me know

    one weird thing is the graph for my lan the incoming is low as it doesnt match the wan graph as seen in pic below, why i dont know as everything is working as expected, opt1 is connected to my wifi router as an ap, opt2(which is really the previous lan nic) is connected to a switch




  • @stephenw10:

    If you have already assigned all the available NICs you won't see a + sign. (As far as I can remember!)

    Steve

    This seems to be the case for me.  I deleted my 3rd interface and I got a + sign to add it back.  When I did this, it just added it back automatically and then no more plus sign.

    Wonder why the difference and how someone is supposed to add the virtual adapters that seem to be required for the process the op is trying to do.

    Should creating the virtual interface be skipped and just bridge the two physical connections?



  • You don't necessarily need to assign the created bridge interface.
    From the description in this thread it appears as if the bridge was never created in the first place.



  • @GruensFroeschli:

    You don't necessarily need to assign the created bridge interface.
    From the description in this thread it appears as if the bridge was never created in the first place.

    thats correct as the tuts and howto posts ive read it states to create a virtual interface first then create the bridge

    This seems to be the case for me.  I deleted my 3rd interface and I got a + sign to add it back.  When I did this, it just added it back automatically and then no more plus sign.

    Wonder why the difference and how someone is supposed to add the virtual adapters that seem to be required for the process the op is trying to do.

    Should creating the virtual interface be skipped and just bridge the two physical connections?

    you could be right, just bridge the lan and opt1 interfaces, opt1 should be set to none in its settings, you will be lock out as ive tried this b4 but maybe at the console do a reboot and make sure lan is the dhcp server, i will test this out. the pf docs states to just add a wireless router in ap mode and connect to the extra nic and all should be well but the router doesnt get a ip address since we havent bridged it to the lan interface



  • @vincom:

    you could be right, just bridge the lan and opt1 interfaces, opt1 should be set to none in its settings, you will be lock out as ive tried this b4 but maybe at the console do a reboot and make sure lan is the dhcp server, i will test this out. the pf docs states to just add a wireless router in ap mode and connect to the extra nic and all should be well but the router doesnt get a ip address since we havent bridged it to the lan interface

    nope that didnt work, so in cunclusion, you need to create a bridge for lan and opt1(connected to wifi ap router)
    this will add the + sign in the assignments page, clicking that will add the opt2 interface which has the bridge0 port.
    enable opt2, then reassign the port bridge0 to lan, and your lan port to the opt2, see pic below.
    when clicking save you will be locked out from the gui, from console reboot and see if wan still gets an ip(im on cable) and lan has a static ip, is the dhcp server and from the gui that it has a firewall rule.
    i have opt1 and opt2 set to none for ip's in their settings page and no firewall rule
    im not sure if the System -> Advanced -> System Tunables have to be edited as it worked w/out it but did so anyways
    net.link.bridge.pfil_member =0
    net.link.bridge.pfil_bridge =1
    i have tested both wired and wireless comps on shelids up test page https://www.grc.com/x/ne.dll?bh0bkyd2 and all is stealth.

    ![pfsense interface assignment4.jpg](/public/imported_attachments/1/pfsense interface assignment4.jpg)
    ![pfsense interface assignment4.jpg_thumb](/public/imported_attachments/1/pfsense interface assignment4.jpg_thumb)



  • @vincom:

    @GruensFroeschli:

    You don't necessarily need to assign the created bridge interface.
    From the description in this thread it appears as if the bridge was never created in the first place.

    thats correct as the tuts and howto posts ive read it states to create a virtual interface first then create the bridge

    Creating the bridge is what creates the virtual interface.



  • I'm running the x86 version now and get the same + missing when all physical nics have been assigned.

    As for the op trying to bridge, I don't know why it would matter, but have you tried setting the wap's ip to static and see if it just works after that?

    Edit:  oh, just wondering, if you want the lan and wap bridged to the same network, why not just plug it into the switch on the lan?  Can you still control traffic between them once bridged?



  • @GruensFroeschli:

    @vincom:

    @GruensFroeschli:

    You don't necessarily need to assign the created bridge interface.
    From the description in this thread it appears as if the bridge was never created in the first place.

    thats correct as the tuts and howto posts ive read it states to create a virtual interface first then create the bridge

    Creating the bridge is what creates the virtual interface.

    i know that now but the howto posts dont state that, they state to click the + sign to add a virtual then bridge the physical opt1 and the virtual opt2 and then reasign the lan port.

    @joebleed:

    I'm running the x86 version now and get the same + missing when all physical nics have been assigned.

    As for the op trying to bridge, I don't know why it would matter, but have you tried setting the wap's ip to static and see if it just works after that?

    Edit:  oh, just wondering, if you want the lan and wap bridged to the same network, why not just plug it into the switch on the lan?  Can you still control traffic between them once bridged?

    i had the extra gig nic and made a project for myself and in doing so learn more about pf