New install - interfaces configured and active but ping fails?



  • im quite new to pfsense and have run into some difficulties. I have been playing with it in a virtual machine to get a feel for it and figured it was time to try it out for real , so i have thrown a computer together out of spare parts and loaded pfsense on it.

    Where the trouble starts is that I have set up the interfaces correctly, (i think?) assigned lan and wan, given them an IP address and all that, but I am unable to access the web gui through the lan interface, or even ping it. pfsense is detecting the interfaces and showing they are active, and they go down and up when when i unplug/plug in the cables, so it wouldnt be a driver problem would it?

    when I did this in vmware it just worked. is there some extra step or something i need to do when doing this on a real machine?

    the computar:
    AUSU A8N-VM motherboard, onboard ethernet assigned as WAN
    HP NC1020 PCI assigned as LAN

    tried swapping these around but same result.
    also tried using a TF-3239DL but no success there either


  • Rebel Alliance Global Moderator

    The default rules on lan are allow all.  So if your on the network you should be able to ping it.  What network are you using the default?  What IP does the machine your trying to ping pfsense lan have?  Is it dhcp or static?  Are you getting your dhcp from pfsense?

    This really should be out of the box working.  Basic troubleshooting of connectivity is the first step.

    Is your machine your trying to ping pfsense lan IP, on that lan.. Can you get the mac address of pfsense.. Try pinging it - look on your machine arp table.. arp -a, do you see pfsense mac address?



  • thanks for the reply

    everything is static at this stage while im trying to get it working. the LAN interface is set to 192.168.2.1/24 and assigned the lan computer the ip of 192.168.2.10/24

    there is no sign of the pfsense mac address in the lan pc's arp table either :(


  • Rebel Alliance Global Moderator

    Well if your not seeing the mac in the clients arp table - your not going to do anything now are you.

    So either pfsense doesn't think that is its IP, or you connection is issue is layer 1 based.

    Check your cables - are you connected to the same switch as pfsense.. Is this a managed switch or dumb switch? But if you do not even see the mac address of pfsense how are you going to do anything?



  • is your comp connected directly to the lan port on pf, if not start there as it could be cables(swap them out).
    if not connected directly still could be cable or switch/router issue.
    what is the lan status from the console



  • im fairly certain its not a layer 1 problem. im using a unmanaged switch from the LAN interface which is known to be good (i use it often). tested the cables and there is no problems with them, tried other cables too just for good messure.

    as suggested I also tried plugging a pc directly into the LAN interface but made no difference.

    the pfsense console says the connection is up, here is the output from the ifconfig command

    ifconfig fwip0
    fwip0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    lladdr 0.11.d8.0.0.91.8d.5a.a.2.ff.fe.0.0.0.0
    inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255
    inet6 fe80::211:d800:91:8d5a%fwip0 prefixlen 64 scopeid 0x2
    nd6 options=43 <performnud,accept_rtadv>Im going to have another dig through my box of old computer parts later and see if i cant find another working mobo and a cpu that fits, maybe it will work on that</performnud,accept_rtadv></up,broadcast,running,simplex,multicast>



  • i think your hw is fine since it boots, your nics idk.
    dont manually assign the ip address for lan, just go through the setup process and assign the nics to appropriate interface(wan, lan) and let pf do the rest, it should default to 192.168.1.1 and set it as the dhcp server


  • Rebel Alliance Global Moderator

    fwip0

    So your trying to do this over Firewire??

    That is not the right nic for ethernet..  That is for sure.  Do you even see a actual mac address on it ;)

    Did you apply the wrong IP to the wrong nic.. I would suggest you post up your whole ipconfig.  But yeah if your plugging into a ethernet port, pfsense has that IP on its firewire port.



  • so fwip is supposed to be firewire? this could be a potential lead on the problem then. this seems weird though because I assigned the interfaces with auto detection (where it tells you to plug in the interface and detects it going up)

    could the problem be a driver issue causing it to recognize the ethernet nic as firewire?


  • Rebel Alliance Global Moderator

    Yes FWIP is firewire interface

    http://www.freebsd.org/cgi/man.cgi?query=fwip&apropos=0&sektion=0&manpath=FreeBSD+8.3-RELEASE&arch=default&format=html

    What is the output of your whole ifconfig - what other interfaces do you see.  From the output you provided you assigned that IP address to the firewire interface.

    Do you see a em0 em1, or re0, re1, etc.  Depending on the type of nic and its driver would determine what its called.

    That would clearly explain your issue though.



  • well here is the output of ifconfig -a. there is too much there to type out by hand so i took a photo. this was just after running through assigning the interfaces again so it will be using the defaults

    http://img850.imageshack.us/img850/5148/a246.jpg

    i noticed something quite interesting this time with the auto detection. it seems to be detecting one interface going up but then assigning another one

    http://img802.imageshack.us/img802/8906/akx5.jpg

    ill try manually assigning the interfaces later and see if that makes a difference



  • @cooonips:

    well here is the output of ifconfig -a. there is too much there to type out by hand so i took a photo. this was just after running through assigning the interfaces again so it will be using the defaults

    http://img850.imageshack.us/img850/5148/a246.jpg

    i noticed something quite interesting this time with the auto detection. it seems to be detecting one interface going up but then assigning another one

    http://img802.imageshack.us/img802/8906/akx5.jpg

    ill try manually assigning the interfaces later and see if that makes a difference

    The second pic is what u need to worry about, thats not right, concentrate your efforts in assigning the nics to wan and lan but u would have to figure out why pf is messing up the interfaces.
    keep the installed nics and peripherals to a min., less hw installed/enabled the easier it is to configure pf, only have 2 nics enabled and installed.
    could be driver issues, mobo, bad nics, unsupported nics, nics not inserted properly, bad install,  etc.


  • Rebel Alliance Global Moderator

    Ok ? For starters why are you using 2.03??  2.1 is current release.

    2nd - do you have anything connected to your firewire port?  Can you not disable them in your bios? Pull the card?



  • SUCCESS!

    I manually assigned the interfaces to what they should be and its all working now! :)
    disabled all the other stuff in the bios too

    im just using 2.03 since its the one i already have, suppose i should get the up to date one before going further

    Thanks for the help  ;D ;D ;D ;D ;D ;D ;D