WAN interface keep dropping internet connection every 10 min



  • I need help… Some how my WAN interface keep dropping internet connection every 10 min. I have to restart pf or go to WAN interface and save (do nothing just save) then it works for 10 min. I am able to log inn into pfbox via LAN. If some one can help me to find out what's wrong with my box or something else. Following is the system log...

    Last 50 system log entries

    Nov 30 18:20:40 php: rc.linkup: The command '/sbin/ifconfig 'bge0' inet delete' returned exit code '1', the output was 'ifconfig: ioctl (SIOCDIFADDR): Can't assign requested address'
    Nov 30 18:20:42 check_reload_status: updating dyndns wan
    Nov 30 18:20:51 ntpd_intres[56122]: host name not found: 0.pfsense.pool.ntp.org
    Nov 30 18:20:51 check_reload_status: Linkup starting bge0
    Nov 30 18:20:51 kernel: bge0: link state changed to DOWN
    Nov 30 18:20:54 check_reload_status: Linkup starting bge0
    Nov 30 18:20:54 kernel: bge0: link state changed to UP
    Nov 30 18:20:54 php: rc.linkup: DEVD Ethernet detached event for wan
    Nov 30 18:20:54 php: rc.linkup: The command '/sbin/dhclient -c /var/etc/dhclient_wan.conf bge0 > /tmp/bge0_output 2> /tmp/bge0_error_output' returned exit code '15', the output was ''
    Nov 30 18:20:56 php: rc.linkup: DEVD Ethernet attached event for wan
    Nov 30 18:20:56 php: rc.linkup: HOTPLUG: Configuring interface wan
    Nov 30 18:20:56 php: rc.linkup: The command '/sbin/ifconfig 'bge0' inet delete' returned exit code '1', the output was 'ifconfig: ioctl (SIOCDIFADDR): Can't assign requested address'
    Nov 30 18:20:58 check_reload_status: Syncing firewall
    Nov 30 18:20:58 check_reload_status: updating dyndns wan
    Nov 30 18:21:01 php: rc.linkup: The command '/sbin/dhclient -c /var/etc/dhclient_wan.conf bge0 > /tmp/bge0_output 2> /tmp/bge0_error_output' returned exit code '15', the output was ''
    Nov 30 18:21:02 php: /interfaces.php: The command '/sbin/ifconfig 'bge0' inet delete' returned exit code '1', the output was 'ifconfig: ioctl (SIOCDIFADDR): Can't assign requested address'
    Nov 30 18:21:05 check_reload_status: rc.newwanip starting bge0
    Nov 30 18:21:05 php: /interfaces.php: ROUTING: setting default route to 192.168.0.1
    Nov 30 18:21:08 php: rc.newwanip: rc.newwanip: Informational is starting bge0.
    Nov 30 18:21:08 php: rc.newwanip: rc.newwanip: on (IP address: 192.168.0.13) (interface: wan) (real interface: bge0).
    Nov 30 18:21:08 php: rc.newwanip: ROUTING: setting default route to 192.168.0.1
    Nov 30 18:21:12 check_reload_status: Reloading filter
    Nov 30 18:21:12 php: /interfaces.php: Creating rrd update script
    Nov 30 18:21:13 php: rc.newwanip: Resyncing OpenVPN instances for interface WAN.
    Nov 30 18:21:13 php: rc.newwanip: Creating rrd update script
    Nov 30 18:21:15 php: rc.newwanip: pfSense package system has detected an ip change 192.168.0.13 -> 192.168.0.13 … Restarting packages.
    Nov 30 18:21:15 check_reload_status: Starting packages
    Nov 30 18:21:15 ntpd_intres[56122]: ntpd exiting on signal 15
    Nov 30 18:21:17 check_reload_status: updating dyndns WAN_DHCP
    Nov 30 18:21:17 check_reload_status: Restarting ipsec tunnels
    Nov 30 18:21:17 check_reload_status: Restarting OpenVPN tunnels/interfaces
    Nov 30 18:21:18 php: rc.start_packages: Restarting/Starting all packages.
    Nov 30 18:21:18 php: rc.start_packages: No pfBlocker action during boot process.
    Nov 30 18:21:19 php: rc.start_packages: No pfBlocker action during boot process.
    Nov 30 18:21:19 php: rc.start_packages: No pfBlocker action during boot process.
    Nov 30 18:21:19 php: rc.start_packages: No pfBlocker action during boot process.
    Nov 30 18:21:23 php: rc.start_packages: Reloading Squid for configuration sync
    Nov 30 18:21:24 php: rc.start_packages: Reloading Squid for configuration sync
    Nov 30 18:21:25 php: rc.start_packages: Reloading Squid for configuration sync
    Nov 30 18:21:25 php: rc.start_packages: Not calling package sync code for dependency squid of squid because some include files are missing.
    Nov 30 18:21:25 php: rc.start_packages: Reloading Squid for configuration sync
    Nov 30 18:21:26 php: rc.start_packages: Reloading Squid for configuration sync
    Nov 30 18:21:27 php: rc.start_packages: Reloading Squid for configuration sync
    Nov 30 18:21:27 php: rc.start_packages: Reloading Squid for configuration sync
    Nov 30 18:21:32 squid[57524]: Squid Parent: child process 58200 exited with status 0
    Nov 30 18:21:33 php: rc.start_packages: The command '/usr/local/etc/rc.d/squid.sh stop' returned exit code '1', the output was ''
    Nov 30 18:21:35 squid[17697]: Squid Parent: child process 18305 started
    Nov 30 18:29:16 ntpd_intres[69225]: host name not found: 0.pfsense.pool.ntp.org
    Nov 30 18:31:50 ntpd_intres[69225]: host name not found: 0.pfsense.pool.ntp.org
    Nov 30 18:35:24 ntpd_intres[69225]: host name not found: 0.pfsense.pool.ntp.org
    Diagnostics: System Activity

    last pid: 76623;  load averages:  0.25,  0.30,  0.65  up 2+03:31:04    18:39:31
    200 processes: 3 running, 176 sleeping, 21 waiting

    Mem: 165M Active, 636M Inact, 165M Wired, 112M Buf, 958M Free
    Swap: 4096M Total, 4096M Free

    PID USERNAME PRI NICE  SIZE    RES STATE  C  TIME  WCPU COMMAND
      11 root    171 ki31    0K    16K RUN    1  48.8H 99.66% [idle{idle: cpu1}]
      11 root    171 ki31    0K    16K CPU0    0  49.5H 98.19% [idle{idle: cpu0}]
    53820 root      47    0 80276K 30920K piperd  1  0:05  1.46% /usr/local/bin/php{php}
      253 root      76  20  3352K  1192K kqread  1  79:41  0.00% /usr/local/sbin/check_reload_status
      12 root    -32    -    0K  168K WAIT    0  14:16  0.00% [intr{swi4: clock}]
        0 root    -68    0    0K    96K -      0  12:32  0.00% [kernel{dummynet}]
      12 root    -68    -    0K  168K WAIT    0  5:45  0.00% [intr{irq17: bge0 em1}]
        0 root    -68    0    0K    96K -      0  4:19  0.00% [kernel{em1 taskq}]
      12 root    -64    -    0K  168K WAIT    0  2:15  0.00% [intr{irq23: uhci3 ehc}]
      21 root      20    -    0K    8K syncer  1  1:14  0.00% [syncer]
        0 root    -16    0    0K    96K sched  1  0:49  0.00% [kernel{swapper}]
      15 root    -44    -    0K  256K -      1  0:41  0.00% [usb{usbus7}]
      12 root    -40    -    0K  168K WAIT    0  0:33  0.00% [intr{swi2: cambio}]
      14 root    -16    -    0K    8K -      1  0:31  0.00% [yarrow]
        4 root      -8    -    0K    8K -      0  0:21  0.00% [g_down]
      12 root    -32    -    0K  168K WAIT    0  0:19  0.00% [intr{swi4: clock}]
        3 root      -8    -    0K    8K -      0  0:13  0.00% [g_up]
    30692 root      44    0  9028K  6804K kqread  1  0:13  0.00% /usr/local/sbin/lighttpd -f /var/etc/lighty

    Status: Dashboard

    Name super.localdomain
    Version 2.1-RELEASE (i386)
    built on Wed Sep 11 18:16:50 EDT 2013
    FreeBSD 8.3-RELEASE-p11

    You are on the latest version.
    Platform pfSense
    CPU Type Intel(R) Atom(TM) CPU N280 @ 1.66GHz
    2 CPUs: 1 package(s) x 1 core(s) x 2 HTT threads
    Uptime 2 Days 03 Hours 31 Minutes 57 Seconds
    Current date/time
    Sat Nov 30 18:40:24 CST 2013
    DNS server(s) 127.0.0.1
    97.64.183.164
    97.64.209.37
    192.168.0.1
    Last config change Sat Nov 30 18:37:31 CST 2013
    State table size left barred bargray barright bar
    0% (44/196000)
    Show states
    MBUF Usage left barred bargray barright bar
    10% (2664/25600)
    Load average
    0.18, 0.27, 0.62
    CPU usage left barred bargray barright bar 
    (Updating in 10 seconds)
    Memory usage left barred bargray barright bar 
    17% of 1960 MB
    SWAP usage left barred bargray barright bar 
    0% of 4096 MB
    Disk usage left barred bargray barright bar 
    4% of 32G
    Interfaces minimize  close
    cablenic  WAN      (DHCP)
    up 1000baseT <full-duplex,flowcontrol,master,rxpause,txpause>192.168.0.13
    cablenic  LAN
    up 1000baseT <full-duplex>192.168.1.1
    cablenic  HOTSPOT
    up 1000baseT <full-duplex>10.10.10.1
    Captive Portal Status minimize  close
    IP address MAC address Username
    10.10.10.66 74🇩🇪2b:c7:88:c1 Guest x
    Traffic Graphs configure  minimize  close
    Current WAN Traffic Show wan traffic graph
    Current LAN Traffic Show lan traffic graph
    Current HOTSPOT Traffic Show opt1 traffic graph
    Gateways minimize  close
    Name
    RTT Loss Status
    WAN_DHCP
    192.168.0.1
    0.6ms 0%
    Online</full-duplex></full-duplex></full-duplex,flowcontrol,master,rxpause,txpause>



  • Try turning off "gateway monitoring". Go to routing / select approperiate wan by clicking on E / check "disable gateway monitoring"



  • Could also be a dodgy WAN cable or the device on the other end of the WAN cable - if there are short transitions of the connection going down then quickly back up again, then it has been known that the system sees the hardware down, but somehow misses processing the hardware coming back again.
    You can probably also recover by going to Status->Interfaces and doing a release and renew of the WAN DHCP address.
    Wiggle the WAN cable  ;)



  • Would be nice with a feature on the pfSense to bring interface up and down if there is no traffic…  Anyone tried creating a custom script for this ?


Log in to reply