Can't connect to RDP using DyamicDNS from provider



  • Hello.

    I'm trying to make my server lab for testing something and I'm using pfSense to better emulate environment.

    I have in VirtualBox 2 servers with Windows Server 2012 R2 and 1 pfSense 2.1.
    First is domain controller and I changed default RDP port to 3388 and second is host for my programs (for Web Access, etc.)
    and RDP port is 3389.

    Network setup is : on servers - internal network
    on router : 1st adapter - Bridged, 2nd adapter - internal.

    I forwarded 3389 and 3388 in pfSense and when from host with WAN address connect to server it works.
    But when I use DynamicDNS (DDNS) that I got from my ISP, I can't connect. DDNS is in name.provider.com.

    Firewall on servers are disabled (I can't connect to both) but when connect servers direct to WAN I can use my DDNS to remote control them.

    How to fix this problem ?

    Thanks in advance.

    Edit : Ports are forwarded on WAN router, and I tried to make rules for RDP on pfSense but still can't connect.



  • Can you explain how the Port Forward was setup?

    Best Way is to go: Firewall > NAT > Port Forward
      –> WAN Address with Destination Address (WAN) Destination Port 3388 ==> Redirect Target IP(Your First Host)/Port 3389
      –> WAN Address with Destination Address (WAN) Destination Port 3389 ==> Redirect Target IP(Your Second Host)/Port 3389
            Filter rule association: (When adding leave the option to Add Associated Filter Rule)

    Apply the Settings :)



  • Can you provide a topology?  It sounds like you have Internet <> Router 1 <> pfsense

    If this is correct, have you set port forwards on Router 1?  If not, you need to forward these ports to the IP address of the WAN interface on pfSense.