Alix 2D13 - pfSense 2.1 - Cable modem - a bug?



  • Use:
    Alix 2D13 with 2.1-RELEASE  (i386).
    1% CPU
    42% memory
    20% disk

    Cable Modem:
    Cisco EPC3010 EuroDocsis 3.0 Cable Modem
    Firmware:
    e3000-v302r125551-111216c.bin
    URL:
    http://192.168.100.1/Docsis_system.asp

    Story:

    If my ISP have a problem, doing upgrade on the cables where I live.. my Internet is cut off…
    When it gets back on - my Alix does not do anything about it..

    WAN is showing the same IP.
    WAN "link" is showing green.
    I login pfSense web interface try Pinging google.com - does not work! :(

    My solution before (when I had a motorola cable modem, and pfSense 1.x) was to have a linux box run a bash script, that would automatically reboot the cable modem.
    This script is today updated and works (only rebooting) for my Cisco cable modem:

    
    #!/bin/bash
    #
    # put -xv after bash to debug
    #
    HOSTS="google.com"
    COUNT=2
    
    #debug
    echo "HOSTS: " $HOSTS
    echo "COUNT: " $COUNT
    ######
    for myHost in $HOSTS
    do
      counting=$(ping -c $COUNT $myHost | grep 'received' | awk -F',' '{ print $2 }' | awk '{ print $1 }')
    
      #debug
      echo "counting: " $counting
      ######
      if [ $counting -eq 2 ]; then
    
        #debug
        echo "count is: " $counting
        echo "Host : $myHost is UP (ping OK) at $(date)"
        ######
        echo "Host : $myHost is UP (ping OK) at $(date)" >> /root/nyttig/pingcheck/ping-checker.txt
    
      else
        # 100% failed
        #debug
        echo "Host : $myHost is down (ping failed) at $(date)"
        echo "Host : $myHost is down (ping failed $counting times..) Rebooting modem.."
        ######
        echo "Host : $myHost is down (ping failed) at $(date)" >> /root/nyttig/pingcheck/ping-checker.txt
        echo "Host : $myHost is down (ping failed $counting times..) Rebooting modem.." >> /root/nyttig/pingcheck/ping-checker.txt
    #    Motorola modem
    #    REBOOT_MODEM=`curl http://192.168.100.1/goform/gscan -d SADownStartingFrequency=687000000`
    
    #   Cisco modem
        REBOOT_MODEM=`curl -d "SADownStartingFrequency=687000000" http://192.168.100.1/goform/ChannelsSelection`
        $reboot_modem >> /root/nyttig/pingcheck/ping-checker.txt
    fi
    done
    
    

    Problem:
    It does not help to reboot cable modem manually.
    It does not help to reboot with the script above. (I know the script works ;))
    It does not help either to reboot the Alix 2D13 from the pfSense web interface.
    The Alix 2D13 WAN port is blinking.. but not they way it should.. abit random.. (normally it blinks very fast) ??

    Solution:
    (a bug??): is to disconnect and reconnect ONLY the WAN cable. After 5-7 seconds Internet is back/OK.
    OR
    disconnect the Power on the Alix 2D13 board. Reinsert power and it will get only again.

    Question:
    Is this a problem with the Cable Modem ? - or is it a problem with Alix 2D13 board ?  or  a Alix/pfsense combination with the pfSense 2.1 version ?



  • Couple thoughts.

    User a different port for WAN to determine if you have a bad NIC.

    Physically disconnecting the interface solves your problem.  Try bringing the interface down via command line and back up.  If that works you can modify your script.

    Seth



  • Alix 2D13 only has 3 ports. But I might be able to switch the "configure" and setup this a wan port. Will check out this!

    Also found a command to bring interface up/down.
    http://forum.pfsense.org/index.php?topic=44416.0

    
    /etc/rc.linkup opt1 start
    
    

    ..but the problem is that - how can I run this command from a linux server or script - when I'm prompted a user interface (se under here) when I login to pfSense ?

    
    *** Welcome to pfSense 2.1-RELEASE-nanobsd (i386) on pfsense ***
    
     WAN (wan)       -> vr1        -> v4/DHCP4: 84.xxx.xxx.xxx/18
     LAN (lan)       -> vr0        -> v4: 192.168.0.1/24
     CONFIGURE (opt1) -> vr2        -> v4: 10.0.0.250/32
    
     0) Logout (SSH only)                  8) Shell
     1) Assign Interfaces                  9) pfTop
     2) Set interface(s) IP address       10) Filter Logs
     3) Reset webConfigurator password    11) Restart webConfigurator
     4) Reset to factory defaults         12) pfSense Developer Shell
     5) Reboot system                     13) Upgrade from console
     6) Halt system                       14) Disable Secure Shell (sshd)
     7) Ping host                         15) Restore recent configuration
    
    




  • This problem has happened again :-/
    Internet just disconnects..

    And when I check - cable modem is online.
    Called the ISP and they confirm that the cable modem is online too.

    And the Alix 2D13 just blinks now and then.. (and not fast as it should)

    Frequency:
    This happens now and then.. it has now been a couple of days since this happened last time…
    I would expect it to happen rapid if it was a hardware failure..

    Solution so far:

    disconnect the WAN cable for 2 seconds.
    Insert WAN cable..
    5-7 seconds.. and the internet is working again.
    (or build a script that takes the WAN interface up and down with CLI)

    But Why ?

    • is this the Alix 2D13 WAN port failing by somehow ?
    • is the pfSense 2.1 giving/stopping/hanging ?

    Todo:
    How can I trace in pfSense 2.1 - that pfSense is not causing the problem ? (logging etc)



  • I had a problem some time ago with a desktop switch that had dodgy power, it would glitch for a moment every now and then. I had an Alix2D13 WAN plugged into it as a test system. The WAN would lose its IP address and not regain it. I could get the WAN address back again by:
    a) cleanly disconnect the WAN cable and reconnect it; or
    b) From Status->Interfaces release and renew; or
    c) Reboot or power-cycle the Alix.

    I tried to reproduce it just now by disconnecting and reconnecting the WAN cable as quickly as I could - but no luck.
    If your symptoms and fixes are the same, then maybe there are very quick interruptions on the WAN cable, enough that pfSense gets the signal that something went down, but so quick that it missed the signal that things are up again.

    I have no idea if this scenario is still a potential problem, as it is a bit difficult to reliably simulate!



  • Yes, Yes phil.davis.

    This excactly the symptoms!

    And I do have a switch in the middle; http://www.newegg.com/Product/Product.aspx?Item=N82E16833122111

    I use the switch so that both my voip phones and Alix gets an external IP and from the cable modem.

    …thinking..
    Maybe the netgear is causing the problem.. hmm.. Alix has been terminated to the same ethernet-switch-port..  the problems comes now and then.
    also had problems with a network cable on this port too... hmm...

    Will try:
    I will try changing the switch and see if the problem goes away.



  • @kilko:

    I use the switch so that both my voip phones and Alix gets an external IP and from the cable modem.

    Usually you only get one external IP address from your ISP. If your VOIP phone catches it what's left for your pfSense?
    Kill the switch in front of your pfSense and put the phone behind pfSense.



  • Sorry for missing the switch part. But the switch has not had any issue with the voip phones or the alix before.
    And a ethernet port going bad is quite seldom.. specially on a switch. (but I have to check this out..)

    Our ISP, have cable modems are able to deliver several external IPs.
    I have 3 voip phones and 1 Alix connected to the switch.
    They all get separate external IPs.

    Reson for using the switch is another story - when I connected all the voip phones behind the Alix, they connect fine.
    Then ISP goes down. Reboot Cable modem. And the voip does not connect…. but all PCs does it.
    I have been setting and using forum to find ways and switches/commands to tweak voip, QoS and other tools.
    Even bought the book.. but it gave so much hassle..  that I put them in directly into the switch, instead of behind the Alix.
    No firewall protection u say? - I know.. but in the long run, it works.. all the time! (only cable modem has to be rebooted.. and they reconnect again)



  • @kilko:

    Our ISP, have cable modems are able to deliver several external IPs.
    I have 3 voip phones and 1 Alix connected to the switch. They all get separate external IPs.

    I stand corrected. If only we could get such "features".
    With Kabel-Deutschland you only get DSL-light which has a private IPv4 on WAN. Don't know if it's dual stack, though.

    How is your pfSense WAN configured? Your modem probably isn't bridging, right?



  • WAN is configures DHCP.
    ISP releases the IP after 1 week.. (i'm told) So my Alix have had the same IP for years.
    ISP do offer dual-stack, using  DHCPv6 for both IP and prefix. But they do not offer SLAAC.

    I believe the cable modem is in bridge mode, which just passes through traffic. ISP is then giving me 4 external IPs that I can work with.

    phil.davis;
    I have replaced the Netgear GS108 switch for a other one.
    Now I'm using D-Link DES-1005D.
    Lets see if I get any switch-power-hiccups now..

    Also I have purchased a second Alix 2D13.
    And if D-Link DES-1005D have the "same symptoms". I will try using this second Alix box.

    Backup Alix:
    I made a clone of the Compact Card that is in use today, with HDD Raw Copy Tool. http://hddguru.com/software/HDD-Raw-Copy-Tool/HDDRawCopy1.10Portable.exe
    Tested the copied CF card and it works perfectly.
    I found this to be a good way of keeping "physical" copies of the card.
    Also very good to use - before upgrading the pfSense, if something fails after upgrade etc..
    (and up to now.. I have not had any problems with the pfSense auto-upgrading system. Thanx pfSense team :D )



  • ..after some time now. The system have been up running 24/7 and have not had any issues. :-?

    I starting to believe that my ISP is doing "upgrade" or some "fixing" to the coax wire or to the central that we are connected.. causing the suddenly that the network stops sending ip-traffic although the lights are "on"..



  • My solution:
    Reboot the pfsense box too:
    https://forum.pfsense.org/index.php/topic,71335.0.html


Log in to reply