PfSense + Multiple Public IP's



  • I have a pfSense with 6 NIC's (em0,em1,igb3,igb2,igb1,igb0) and a /29 (5 Public Address) and am trying to achieve this setup:

    EM0(Wan) –--------------------- EM1(LAN) ----------  Private Network
                                          |----- IGB3 (Public IP)  --- Ubuntu Server
                                          |----- IGB2 (Public IP)  --- Ubuntu Server2

    I have configured EM0 in a bridge to IGB3 (via interfaces -> Assign -> Bridges ) and static'd the address (second public IP in the /29) in the Ubuntu Server. I have made no IP assignments in the pfSense in regards to the bridge but I cannot seem to get any traffic to pass to the Ubuntu Server (I have attempted to connect to it via SSH and it is rejected). The Ubuntu Servers are connected NIC to NIC to the pfSense and the links are showing up @ 1000Mb. If I remote into a system on the LAN and run a ping to the public IP address of IGB3 I can sucessfully ping and SSH from the LAN. However if I run a ping/ssh from my home machine to the server on IGB3 no traffic passes.

    Anyone have an idea how to correct this ?



  • Went into CLI and manually created bridge and assigned interfaces as shown below

    [2.1-RELEASE][root@pfSense.localdomain]/root(23): ifconfig bridge create
    bridge0
    [2.1-RELEASE][root@pfSense.localdomain]/root(24): ifconfig bridge0 addm igb3 addm igb2 addm em0 up

    This appears to have worked I just need to figure out how to get it to create bridges on start up now, which I believe if I edit /etc/rc.conf I can do.



  • Could anyone explain why the process wasn't working via the webGUI or if I was incorrectly configuring the bridges in the webGUI ?