Port forwarding solution for ARMA3 - need to enable "static port" option.



  • Hi guys, after speding a day ripping out my hair, (and I do not have much left), I discovered this obscure post which provided a solution…

    You may use other protocols, like some games amongst other things, that do not work properly when the source port gets rewritten. To disable this functionality, you need to use the static port option. Click Firewall -> NAT, and the Outbound tab. Click "Manual Outbound NAT rule generation (Advanced Outbound NAT (AON))" and click Save. You will then see a rule at the bottom of the page labeled "Auto created rule for LAN". Click the "e" button to the right of that rule to edit it. Check the "static port" box on that page, and click Save. Apply changes and this behavior will be disabled.

    This allowed arma3 clients to connect to my Arma3 server (behind pfsense).

    I was going to add it to this post as a solution…but it is closed (without saying what the solution was).

    Perhaps this could be added to the trouble shooting page?

    Apologies if everyone else already knows this as a solution, (or there is a better one)..but I thought I'd post it anyway incase it is of some use to others.



  • AWE CRAP!  Just noticed there is a whole forum on here devoted this  :'(

    Well…that was a day i will never get back...but on the bright side...I did learn alot !

    Perhaps there is still some value in updating the NAT doco. though as others may also not immediately assume there is a game forum on here which holds the solution.