How to force launch the webGUI?



  • I used to open GUI using 192.168.xx.xx for the longest time.

    But now I don't really know what happened and the web GUI can't even load. I have not no page to log-in. Please help!


  • Netgate Administrator

    Have you tried https://192.168.xx.xx?
    You could try going to the console (physically or via ssh) and using option 11, restart webconfigurator.
    Does this behaviour span a reboot?

    Steve



  • Yep, I used to launch the GUI easily using my LAN IP. I also tried to reset the webconfigurator using option 11. but availed no access. How do go around with it?

    console shows IP for WAN and IP for LAN but LAN IP when type in the url can not launch the GUI? What did I missed?

    Is there any SSH command in the console that give me access to setuo wizard? so i may recheck if I have reconfigured it wrongly.


  • Netgate Administrator

    You can re-assign the LAN IP from the console. Do you have an IP conflict in your network, something else that's using the default 192.168.1.1 address? (a common address).
    You tried both http and https?

    Steve



  • am not using the 1.1 IP as it is a default.

    my router is 1.10
    my LAN IP is 34.1

    am using https to access my GUI



  • my LAN IP is 34.1

    you on a huge subnet then ?



  • I am using /24 on LAN.

    I decided to begin at 192.168.34.0 and assigned 192.168.34.1 as my LAN IP and this is where I used to access the GUI page for the longest time. I have just upgraded to a leased line connection and I was given 13 usable IPs but when I tried to enter the static IP on pfs box, I cant get an internet from the pfbox LAN, so what I did is I use a router (i know its stupid but its a temporary thing while trying to search why static IP don't work with pf box). The router is fresh new I assigned 192.168.10.0/24 on it.

    So my network map would be:

    Leased Line (LL) >>> Router (192.168.10.0/24)>>>>pfbox (I config the WAN as dhcp then assigned 34.1/24 as LAN IP)

    This map works and no problem at all. But I wish to directly connect my LL to the pfbox. So i played ad entered carefully the needed info on the static WAN then saved it. And then I dont know what went wrong when I tried to access the GUI page from LAN IP which is 34.1 then I can not longer access the page. The GUI page doesnt load at all. So is there any ssh command that i could use to disable tge WAN static thing in my pfbox?


  • Netgate Administrator

    So you can't access the webgui but you can still SSH to the box? What happens if you unplug the WAN cable from the pfSense box? Can you access other sites on the internet from a client behind pfSense? Can they access the router gui at 192.168.10.1?

    From what you're describing I would be looking for an address conflict but I can't see how that might be.

    Steve



  • if i unplug the WAN from the pfbox, then the host machine would get no internet at all and I cant access the router gui unless I connect directly from the router.

    I have an access to the console (I'm running pf on virtualbox so a wnidow for the console alone is available) but no access to the WebGUI page. the 34.1 LAN IP appears to be invalid LAN IP so I can not access anypage (but erorr page)



  • Is there any SSH command to uncheck the Static IP selection in the WAN interface GUI? I would like to select again the DHCP.


  • Netgate Administrator

    You can reset the IP from the console with menu option 2.

    So how is your VM host setup? How does the pfSense VM connect to other machines? Where are you trying to connect to the LAN from?

    You said that it was working until you added the static WAN address. That implies that you have an IP conflict of some sort. However in that case I wouldn't expect you to be able to connect via SSH.  :-\

    Steve


Log in to reply