Multi WAN



  • Boa tarde,

    Pessoal estou implementando o PFsense em minha empresa e estou me deparando com o seguinte problema:

    Tenho 3 placas de rede.

    1 - WAN - Link internet IP Externo
    2 - LAN - 192.168.1.250
    3- LAN - DHCP 10.1.1.1 a 10.1.1.X

    Todas as minhas maquinas da rede, eu coloquei o pfsense como Gateway de internet (192.168.1.250).

    Na mesma empresa que eu trabalho temos um outro LINK de WAN dedicado que chega pra mim no 192.168.0.250 (internet gateway).

    Fui lá e adicionei na placa 2 LAN (192.168.1.250) o GW 192.168.0.250

    Tentei criar um grupo para fazer um FAILOVER, porem quando eu apliquei as regras minha rede caiu!!! ficou instável.

    o que pode estar ocorrendo?

    se desejarem dou um jeito de dar uns prints das telas para ficar melhor explicado.

    abraços.



  • @betox130:

    Fui lá e adicionei na placa 2 LAN (192.168.1.250) o GW 192.168.0.250

    Seu procedimento está errado.

    Cada link de saida deve ter sua propria wan.

    colocar outro link na lan é simplesmente "pular" o firewall



  • Boa noite,

    Marcelloc então deixa e ver se entendi…

    No meu servidor tenho apenas 3 placas, e na placa mãe não tem mais slot, optiplex dell 740...

    Primeira Placa- Uso ip Externo, WAN1 por exemplo, ela tem o ip e o gateway dela...
    Segunda Placa - Uso na rede lan com o IP 192.168.1.250/255.255.0.0 (Que será o meu GW para as maquinas da minha rede)
    Terceira Placa - Pego e coloco um ip 192.168.2.250/255.255.0.0 (WAN2) e o GW dela coloco 192.168.0.250 (que vem a internet).

    Ai configuro o Failover novamente!

    Fazendo assim eu não gero loop na rede? e desta forma estará correto?

    valeu abraços.



  • Sua máscara de rede está imensa.  Não use um /16, baixe a quantidade de hosts para algo mais razoável como por por exemplo um /24, 23 ou 22.


  • Developer Netgate Administrator

    @betox130:

    Boa noite,

    Marcelloc então deixa e ver se entendi…

    No meu servidor tenho apenas 3 placas, e na placa mãe não tem mais slot, optiplex dell 740...

    Primeira Placa- Uso ip Externo, WAN1 por exemplo, ela tem o ip e o gateway dela...
    Segunda Placa - Uso na rede lan com o IP 192.168.1.250/255.255.0.0 (Que será o meu GW para as maquinas da minha rede)
    Terceira Placa - Pego e coloco um ip 192.168.2.250/255.255.0.0 (WAN2) e o GW dela coloco 192.168.0.250 (que vem a internet).

    Ai configuro o Failover novamente!

    Fazendo assim eu não gero loop na rede? e desta forma estará correto?

    valeu abraços.

    O cenario mais usado nesse caso seria:

    WAN1 - IP xx.yy.zz.nn - gateway como está hoje
    LAN - 192.168.1.250 / 255.255.255.0
    WAN2 - 192.168.0.xxx / 255.255.255.0 - gateway 192.168.0.250

    Aí você tem 2 WANs, o outbound NAT será configurado pras duas. A única coisa é que como o IP que você recebe do segundo link é um IP RFC 1918, quem sair por essa rede vai sofrer duplo NAT

    192.168.1.X -> 192.168.0.xxx -> IP do link -> destino

    Enquanto quem sair pelo WAN1 vai sofrer apenas 1 NAT

    192.168.1.X -> IP da WAN1 -> destino


Log in to reply