Unable to communicate to the pfsense package server



  • Hi,

    I have been getting this error when i try to go to the package server.

    Unable to communicate with www.pfsense.com. Please verify DNS and interface configuration, and that pfSense has functional Internet connectivity.

    To do some diagnostics I have gone into Diagnostics –>DNS Lookup and went to www.pfsense.com and see if it resolves it.

    And it gave a dns resolution back.

    I use this in Bridge Mode . PFSense is virtualised and I use it to transparently inspect the usage of bandwidth using bandwidthd. That part works well (just need to confirm the bandwidth usage)!

    I have 1 gateways and 3-4 dns servers

    Two are to my Windows primary and secondary  DNS servers to resolve ip address so i can resolve the last computer names in the internal network, but I have google DNS servers 8.8.8.8 listed there as well.

    I tested in the command prompt as well using fetch -o - http://pfsense.org/package/pkg_config.8.xml but it says no route to host.

    This is funny because I was able to make this work before. I cannot remember what I did to change it to make it this way. Any help appreciated

    I have also done a bit of research. I looked in resolv.conf and found only my Windows  dns server and modem router there.



  • Hi guys,

    I did a lot of reading throughout the weekend on this and decided to create a static route to 192.207.126.26 using my router gateway.

    For posterity as of pfsense 2.1 This is in system–>routing-->routes . I added in the destination network as 192.207.126.26 and 32 for the other option.

    Saved the entry and tested telnet 192.207.126.26 80

    Got a connection and voila the package manager worked as well



  • @Weiyentan:

    Hi guys,

    I did a lot of reading throughout the weekend on this and decided to create a static route to 192.207.126.26 using my router gateway.

    For posterity as of pfsense 2.1 This is in system–>routing-->routes . I added in the destination network as 192.207.126.26 and 32 for the other option.

    Saved the entry and tested telnet 192.207.126.26 80

    Got a connection and voila the package manager worked as well

    Tks a lot man, I've been working in this issue, but it's totally solved now
    thanks very much



  • Did you have it set to GW on your LAN? Or Like was your interface setup?