Postfix problem with smtp



  • hello guys,

    i´ve got a problem with my postfix forwarder. i change my firewall system to a pfsense.
    i configured the postfix package and now i get the following error at system log:



  • The "Operation timed out" message is the one that looks to be the problem.

    What NAT and firewall rules have you got in place?  Is the "IP pfsense" 127.0.0.1 or your WAN address?

    I had a similar problem after updating to postfix recently.  I had to change my config to NAT port 25 connections to 127.0.0.1 and have postfix listen only to loopback.

    By the way, this question should really have been in the Packages forum under the postfix thread.  The postfix package maintainer would be more likely to see it there too.



  • first, thanks for supporting me!

    the "ip pfsense" means not the local ip but rather the static ip from my ISP (WAN).
    I have successfully tested the internal connection to my exchange 2010 mailserver over port 25. I tested this with putty over telnet (port 25).
    When I test the connection from outside of the LAN with the static ip address from my ISP (also over putty) I get the following entry:

    220 pfsense.postfix ESMTP

    When I test this same thing with my old firewall, I get a difficult answer:

    220 FQDN from my Exchange 2010

    My LAN firewall rules are the following(Thats the default rule):

    My WAN firewall rules:

    Are there more informations you need?



  • You don't show a NAT rule but the WAN rule is exactly what I had until recently.  telnet results the same too.

    Disable your current port 25 WAN rule.

    Add a WAN NAT rule (with auto f/w rule) for port 25 to 127.0.0.1 and set postfix to listen on loopback.

    If that works, delete the disabled port 25 rule.

    ![2013-12-16 05-59-12.png](/public/imported_attachments/1/2013-12-16 05-59-12.png)
    ![2013-12-16 05-59-12.png_thumb](/public/imported_attachments/1/2013-12-16 05-59-12.png_thumb)



  • YOU ARE GREAT  ;D ;D finally it works !
    big thanks to you, you made my day !


Log in to reply