Squid3 disappeared



  • Hi,

    Yesterday I wanted to change a reverse proxy setting but the option was no longer in the menu.
    However, Squid3 was still working as the reverse proxy was accepting and redirecting external requests based on URL.

    I decided to look at the packages and Squid3 was not in the list of installed packages but was listed as a package available for installation. So I installed it and went into the menu for configuring the reverse proxy. What turned out was that all my reverse proxy settings were still there.

    So why did it disappear from the menu and was it in the list of not installed packages?



  • @border:

    So why did it disappear from the menu and was it in the list of not installed packages?

    Did you upgraded your pfsense or had to restore a backup?

    It never happened to me.



  • @border:

    Hi,

    Yesterday I wanted to change a reverse proxy setting but the option was no longer in the menu.
    However, Squid3 was still working as the reverse proxy was accepting and redirecting external requests based on URL.

    I decided to look at the packages and Squid3 was not in the list of installed packages but was listed as a package available for installation. So I installed it and went into the menu for configuring the reverse proxy. What turned out was that all my reverse proxy settings were still there.

    So why did it disappear from the menu and was it in the list of not installed packages?

    I just had a the same problem.  All my packages just disappeared.  I am able to fix by reinstalling the packages but it is still an issue.

    Thanks
    Robert



  • No, I did not change anything on the setup (unless an automated update?)…
    I did not have to restore but simply reinstall the package. All settings were still there.

    It would be reassuring to know the reason behind this weird behavior of pfsense.



  • I have around 30 pfSense boxes setup I have seen this problem several times.  Once this week.  All of a sudden there are no packages and everyone claims there have been no changes to the system.

    Thanks
    Robert



  • Hi Robert,

    I am amazed that there are not more reactions to this issues.
    It seems like a serious bug to me…

    regards.


Log in to reply