SOLVED seeks port forwarding help please!



  • Hi all,

    Sorry to ask a question that's no doubt been answered a thousand times but I have read a bit of documentation with no joy!

    Bit of info:

    Router IP: 192.168.0.1
    WAN IP: 192.168.0.10
    LAN IP: 192.168.1.1
    OPT1 IP (Wifi): 192.168.2.254
    E.g. port: 11081
    E.g host to redirect the port to: 192.168.1.10 (obviously on the LAN subnet)

    I'll enclose screenshots for convenience:

    Sky router rule:

    NAT section:

    NAT Port Forward section:

    Firewall rule section:

    Summary of above: Created a router rule to redirect 11081 to the WAN IP

    Turned on NAT in Advanced > Firewall / NAT

    Created a WAN & LAN rule in Firewall > NAT, corresponding Firewall rule created at same stage.

    Check for the open port using online port checking tool and it reports as closed no matter what I do, I'd really appreciate your assistance here!!

    razaz03









  • Anyone please?

    My balls are trickling with desperation.


  • LAYER 8 Global Moderator

    Double nat - why?

    But if the ports inbound to your pfsense wan IP..  Your NAT is wrong.. What is the dest IP here.. Your WAN IP of pfsense..  Nice that you created aliases and all.. But they just make your rules harder to read. They make sense when tere are multiples of something.. Not when there is just 1.



  • @johnpoz:

    Double nat - why?

    But if the ports inbound to your pfsense wan IP..  Your NAT is wrong.. What is the dest IP here.. Your WAN IP of pfsense..  Nice that you created aliases and all.. But they just make your rules harder to read. They make sense when tere are multiples of something.. Not when there is just 1.

    To answer why double NAT, I assume you saw the NAT reflection set to pure NAT.

    To be honest: I don't know why I did that, I enabled it because I saw it on a tutorial. Ultimately it seems I need to increase my NAT/networking knowledge in general to be comfortable with all of the features.

    Do you have any recommendations for learning? The definitive guide was based on 1.x but I'll still give it a whirl if it's definitive enough to teach this newb.


  • LAYER 8 Global Moderator

    What does your nat "reflection policy" have to do with the pointless act of double natting?  If pfsense is your WAN router, why is it behind a nat?  Why do you think you even need nat reflection.. Why do you think you need to access your services that are on your private lan via the pfsense wan IP?  Why?  Why not just use their actual local IP, or setup your name resolution to resolve whatever fqdn you want to resolve to point to the local IP you want to access when you use that FQDN..  Nat reflection has nothing to do with the actual port forward

    You can make double nat work, but its rarely a good idea and even more rare required.

    What is there to learn in NAT..  Your taking a IP and port on wan, and sending it to different IP and quite often same port, but sometimes different port.  The gui is designed to click through in about 3 seconds and your done.  Only reason yours isn't working is you changed shit that didn't need to be changed.

    If I click to add a new NAT it defaults to the wan address - why did you change that?  Here you want a super ultimate nat guide..  See attached.  Those are normally the only parts of that nat gui you need to touch..  You might need to change tcp to udp, Or maybe you need tcp/udp, etc.  But quite often its just going to be tcp.

    Then you put in your port number, your IP and port number again.  It really should take you all of 5 seconds to create a port forward.

    What part of this does not click??  And I will be happy to explain it.  Its not rocket science..




  • @johnpoz:

    What does your nat "reflection policy" have to do with the pointless act of double natting?  If pfsense is your WAN router, why is it behind a nat?  Why do you think you even need nat reflection.. Why do you think you need to access your services that are on your private lan via the pfsense wan IP?  Why?  Why not just use their actual local IP, or setup your name resolution to resolve whatever fqdn you want to resolve to point to the local IP you want to access when you use that FQDN..  Nat reflection has nothing to do with the actual port forward

    You can make double nat work, but its rarely a good idea and even more rare required.

    What is there to learn in NAT..  Your taking a IP and port on wan, and sending it to different IP and quite often same port, but sometimes different port.  The gui is designed to click through in about 3 seconds and your done.  Only reason yours isn't working is you changed shit that didn't need to be changed.

    If I click to add a new NAT it defaults to the wan address - why did you change that?  Here you want a super ultimate nat guide..  See attached.  Those are normally the only parts of that nat gui you need to touch..  You might need to change tcp to udp, Or maybe you need tcp/udp, etc.  But quite often its just going to be tcp.

    Then you put in your port number, your IP and port number again.  It really should take you all of 5 seconds to create a port forward.

    What part of this does not click??  And I will be happy to explain it.  Its not rocket science..

    Thanks for your help John - you have a peculiar mix of helpful and… je ne sais quoi - but I like a straight-talker and thank you for the assistance :)

    I changed things because I tried the defaults as per guides and it kept printing closed when checking port checkers (Looking at the stickies today, perhaps because I checked from the LAN rather than a diff network, or perhaps it's a left-over setting from another guide), did so incorrectly and must've left it there as an oversight - screenshotting the change for your delight.

    Will check this when home but thanks once again.



  • @johnpoz:

    What does your nat "reflection policy" have to do with the pointless act of double natting?  If pfsense is your WAN router, why is it behind a nat?  Why do you think you even need nat reflection.. Why do you think you need to access your services that are on your private lan via the pfsense wan IP?  Why?  Why not just use their actual local IP, or setup your name resolution to resolve whatever fqdn you want to resolve to point to the local IP you want to access when you use that FQDN..  Nat reflection has nothing to do with the actual port forward

    You can make double nat work, but its rarely a good idea and even more rare required.

    What is there to learn in NAT..  Your taking a IP and port on wan, and sending it to different IP and quite often same port, but sometimes different port.  The gui is designed to click through in about 3 seconds and your done.  Only reason yours isn't working is you changed shit that didn't need to be changed.

    If I click to add a new NAT it defaults to the wan address - why did you change that?  Here you want a super ultimate nat guide..  See attached.  Those are normally the only parts of that nat gui you need to touch..  You might need to change tcp to udp, Or maybe you need tcp/udp, etc.  But quite often its just going to be tcp.

    Then you put in your port number, your IP and port number again.  It really should take you all of 5 seconds to create a port forward.

    What part of this does not click??  And I will be happy to explain it.  Its not rocket science..

    Just tried this today from an external network after redoing my NAT rules. I guess thinking about your questions taught me some lessons about what I'm doing.

    It was appearing as closed because I was trying from the same network and I did double NAT because of a pfSense youtube tutorial :)

    Live and learn, anyway thanks bud


Log in to reply