About access to the internal server



  • Now I want the PC (192.168.3.3)can access to the internal server(192.168.1.2), to do what kind of rules.The topology is as follows



  • You can just allow 192.168.3.3 in on pfSense WAN - add a rule on WAN:
    Pass Source: 192.168.3.3 Destination 192.168.1.2 (and put any protocol, any port, or restrict those how you wish)
    No NAT will happen by default (the connect is coming in from WAN to LAN) and no NAT is really needed here.
    Then PC 192.168.3.3 needs a route to 192.168.1.0/24 through 192.168.3.2 - you can add that as a static route on just that PC (if this is a special thing for that PC) or add that route to the front-end router (192.168.3.1) so that it is more generally known.



  • @phil.davis:

    You can just allow 192.168.3.3 in on pfSense WAN - add a rule on WAN:
    Pass Source: 192.168.3.3 Destination 192.168.1.2 (and put any protocol, any port, or restrict those how you wish)
    No NAT will happen by default (the connect is coming in from WAN to LAN) and no NAT is really needed here.
    Then PC 192.168.3.3 needs a route to 192.168.1.0/24 through 192.168.3.2 - you can add that as a static route on just that PC (if this is a special thing for that PC) or add that route to the front-end router (192.168.3.1) so that it is more generally known.

    I have according to what you said to configure but still can't ping (192.168.1.2 )



  • First make sure that any firewall on 192.168.1.2 is off. Some Windows firewalls will allow ping from their local network, but not from other networks.
    Then from 192.168.3.3 traceroute to 192.168.1.2 - it should go through 192.168.3.2 (and perhaps also report the hop via 192.168.3.1). See where the traceroute has trouble, then look for the routing problem or firewall problem at that point.
    Then post details of the routing table on 192.168.3.3, 192.168.3.1 and Firewall Rules from the pfSense and any other stuff you think might be useful.


  • LAYER 8 Global Moderator

    And who says he is not natting? I bet you all the presents santa is bringing that he is NATTING.  Users just love their double nats ;)

    By default pfsense NATS, so I find it unlikely he disabled this and setup routing on this router in front of pfsense and didn't bother to mention that in his post?

    Sure you can double nat.. Just make sure you forward the ports you want, and make sure disable the block rfc1918 rules.  And you will have to use the pfsense wan IP to get to the boxes behind pfsense.

    If you are not natting.. Then you need to setup the routing correctly on your other router, or need to setup host routing on your 192.168.3.3 box if you expect to get to 192.168.1.anything through pfsense wan IP and also allow for the traffic you want to allow in your firewall tabs on pfsense.

    You will also as mentioned need to make sure the firewall if one on your box behind pfsense allows the traffic from network that is not local to it.


Log in to reply