Sendmail problem



  • Hi All,

    I have a pfsense 2.0.3-RELEASE (amd64) FreeBSD 8.1-RELEASE-p13 which the sendmail was working fine before 20 Dec 2013 but now the system is reporting this error message:
    Sending e-mail on this version of pfSense is not supported. Please use pfSense 2.1 or later.

    The postfix package is 2.10.2 pkg v.2.3.7. Also when I tried to uninstall or reinstall the package, the installer screen show the below:
    Beginning package installation.

    Removing Postfix Forwarder components…
    Tabs items... done.
    Menu items... done.
    Services... done.
    Loading package instructions...
    Deinstall commands...

    Checking in the Available Packages, the postfix package was not found and in the Installed Packages, the postfix package is still there.

    Also after the above, I check in the system logs and I saw this:
    php: /pkg_edit.php: The command 'ln -s /usr/local/bin/perl /usr/bin/perl' returned exit code '1', the output was 'ln: /usr/bin/perl: File exists'

    Checking in the /usr/local/bin,  there was no perl binary:
    -r-xr-xr-x  1 root  wheel    13861 Jun 11  2012 perl-after-upgrade
    -rwxr-xr-x  1 root  wheel    7304 Jun 11  2012 perl5.12.4
    -rwxr-xr-x  1 root  wheel    7424 May  4  2013 perl5.14.2

    Somehow the perl5.16.3 was missing in the system. Is anyone facing the same issue? How do I resolve this?

    Regards.


Log in to reply