Remove F1 Boot Prompt



  • I've read THIS POST and the related DOC but it's not working for me.  I get an error at the end saying it can't write the MBR.  Per the posts I did make sure my sysctl line is correct.

    I realize there was a similar question posted recently but as I'm not running nanobsd I didn't want to hijack his thread.

    Are the above instructions not valid any more and, if not, would someone be able to help me with removing this menu?

    Thanks.


  • Rebel Alliance Global Moderator

    And what disk are you using, you did read the doc about da or ad, etc.  What does your df show.. I used this quite some time ago to remove it from my boot up worked just fine.


  • Rebel Alliance Developer Netgate

    I just followed the directions from the doc wiki article in a VM and it worked fine. It worked when I wrote that page, but I made sure it still worked on 2.1 and it did.

    Make sure you run the sysctl commands it lists.

    My HDD in the VM is ad0, so I ran:

    sysctl kern.geom.debugflags=16
    fdisk -B ad0
    sysctl kern.geom.debugflags=0
    

    And then a reboot showed that the F1 prompt was gone.



  • The drive is a 32GB OCZ SSD.

    The output of df is:

    /dev/ad4s1a  28245852      191118      25795066      1%      /
    devfs                            1                1                    0  100%      /dev
    /dev/md0                3694              36              3364      1%      /var/run
    devfs                            1                1                    0  100%      /var/dhcpd/dev

    I just ran the command against md0 and it was successful but didn't change anything (I hope that wasn't bad).  Running it against ad4s1a, which I assume is what I'm supposed to do, still gives me the error writing to MBR.


  • Rebel Alliance Global Moderator

    So ad4 then vs ad0 ;)  ad4 is your disk, s1a is partition on the disk not the MBR.

    Which is clearly spelled out in the doc ;)

    To remove the boot manager, you need to reinitialize the boot code on the main disk in the system. This is typically ad0 if you use an IDE/SATA disk, or da0 for SCSI or USB, but it may vary. Check the contents of /etc/fstab or the output of "df" to find the disk holding your root slice. For this, we will assume ad0.


  • Rebel Alliance Developer Netgate

    The fdisk command in this case is run on the disk as a whole, not the root slice, so you would use ad4 instead of ad4s1a.

    If it still doesn't work, be sure to copy/paste the exact command you used and the full output here.



  • It worked perfectly, thanks for the help.



  • Sorry for bringing this old post back again. I, too, trying to remove F1 prompt but I'm using GMirror and wanted to ask what's gonna be the device for me? This is what I have:

    [2.4.3-RELEASE][admin@pfs17]/root: df -h
    Filesystem                      Size    Used   Avail Capacity  Mounted on
    /dev/mirror/pfSenseMirrors1a    129G    960M    118G     1%    /
    devfs                           1.0K    1.0K      0B   100%    /dev
    /dev/md0                        3.4M    164K    3.0M     5%    /var/run
    devfs                           1.0K    1.0K      0B   100%    /var/dhcpd/dev
    procfs                          4.0K    4.0K      0B   100%    /proc
    

    fdisk -B pfSenseMirror doesn't look very right to me. There are two underlaying SSD drives working as ada0 and ada2 - how do I do it?

    -San