PfSense 2.1 loose WAN connection after upgrade



  • pfSense 2.1 loose WAN connection after upgrade after 1-2 days. WAN Connection Shows no external IP adress. refresh the config help almost. Reboot solve the problem also.

    my pfSense 2.0.3 Firewall runs for a year without any problems.

    thanks
    sailer



  • What sort of connection is your WAN?

    Anything in the logs at the point of disconnection?



  • I just had the same thing happen to me. Yesterday I upgraded to 2.1 from 2.0.3 (running for at least a year without issue) and both LAN and LAN2 lost Internet.

    While the WAN fetches DHCP just fine from the modem, and I can ping out/DNS from pfsense itself, nothing from the LAN or LAN2 gets to the WAN. I can't even ping through the firewall to the modem even though the WAN IP is on the same subnet as the modem and I have a custom rule just for that.

    I turned on logging for all firewall rules, cleared the logs, and tried getting out again, but nothing is appearing in the logs. Another weird thing is that I need to use the console to start the WebConfigurator on boot before I can access the web interface.

    Sailor - is any of this similar to the issues that you're experiencing?

    I'm about ready to blow it away and start again, but I have a bunch of customized rules, etc, that would be painful to recreate. Any suggestions would be appreciated.

    Thanks.



  • Hello to all and thanks for the help..

    WAN Interface gets a IP adress via DHCP from my ISP.

    nothing special in the logs:

    Dec 23 23:19:38 apinger: alarm canceled: WAN_DHCP(–.--.--.---) *** down ***
    Dec 23 23:19:17 apinger: ALARM: WAN_DHCP(--.--.--.---) *** down ***
    Dec 23 22:51:16 apinger: SIGHUP received, reloading configuration.
    Dec 23 22:09:08 apinger: SIGHUP received, reloading configuration.
    Dec 23 22:09:04 apinger: SIGHUP received, reloading configuration.
    Dec 23 22:09:02 apinger: alarm canceled: WAN_DHCP(--.--.--.---) *** down ***
    Dec 23 22:08:11 apinger: ALARM: WAN_DHCP(--.--.--.---) *** down ***

    It happens once a day if I reboot the System, and more if I just reloading the configuration.

    And it happens quite often if I'm logged into the admin web Interface..

    thanks sailer



  • I've had similar experiences with 2.1. I upgraded my 2.0.3 installation to 2.1, and it cannot get a DHCP address on the WAN. A fresh install had the same issues. Tried on several different systems, and none were able to get a DHPC address. Re-installed 2.0.3, and the WAN works fine.


Log in to reply