RR Failover not so fail proof



  • I have a setup where I have a DSL and a Cable internet connection. It's setup to monitor the ISP's provided DNS server as the gateway monitor. It's setup in round robin method (I think).

    Whenever one internet connection goes down, we can still get online but it's flakey. Some sites time out. It feels like a normal internet connection with a lot of packet loss.

    Any idea how to make it feel like there isn't even a problem at all to the user when one internet connection goes down?

    This is the version I am on:
    2.1-BETA1 (amd64)
    built on Mon Jan 14 11:26:04 EST 2013
    FreeBSD 8.3-RELEASE-p5

    Thanks.

    More details:

    They are setup in a gateway group called "Cluster" both on a Tier 1 stage.
    A LAN firewall rule is setup so all traffic goes thru "CLUSTER"



  • You should upgrade to the release version. Besides that, try going into your gateway group and changing the trigger level to 'packet loss or high latency'. You can also go into the gateway itself and change the monitor IP or tweak the latency and such.



  • @dotdash:

    You should upgrade to the release version. Besides that, try going into your gateway group and changing the trigger level to 'packet loss or high latency'. You can also go into the gateway itself and change the monitor IP or tweak the latency and such.

    Yea I always set it up with packet loss or high latency. Just about every version of pfsense I've ever used in the past couple years have had this issue and I've never really been able to solve it. Changing the variables under advanced options in the edit gateways sections seems to have no affect.



  • Sounds like you have a flakey line. Try setting up two failover pools and split the clients between them- see if the cable or the DSL people complain more. I've never liked round robin with lines that aren't the same.


Log in to reply