Squid-dev v3.3.10 pkg 2.2 - squid.pid not being created or updated



  • I use squid strictly for it's reverse proxy feature.  Before upgrading from squid 2.6, I had first set up a test rig using the squid-dev package and was able to get all the features I needed functioning.  But once I upgraded my production box, of course it doesn't work.  I can't see the difference between the two configurations but I don't believe a config error is necessarily my problem.

    The issue is that I squid will not create nor update it's pid files and possibly others as well.  According to the config below, squid should be creating the file at /var/run/squid.pid but it's not there and squid cries 'ERROR: No running copy'.

    Here's what I've tried:

    1. Manually creating squid.pid with the pid of the squid process as suggested in http://wiki.squid-cache.org/SquidFaq/TroubleShooting#squid:_ERROR:_no_running_copy though this allows me to update my configuration until I need to restart squid, at which point I must manually update the pid file.

    2. kill -HUP <pid>  didn't create nor update squid.pid

    3. Thinking I have a file permission problem, I enabled r/w access for all users on both /var/run and /var/run/squid.pid to see if squid could then create/update the pid file.

    I'm out of ideas and running out of time.  I should note that the configuration backup I created before starting won't restore and the old version of squid I was using previously is not available from the package lists so I'm really out of luck here.

    The config may contain options from my old configuration.

    # This file is automatically generated by pfSense
    # Do not edit manually !
    
    http_port <lanip>:3128
    icp_port 7
    dns_v4_first off
    pid_filename /var/run/squid.pid
    cache_effective_user proxy
    cache_effective_group proxy
    error_default_language en
    icon_directory /usr/local/etc/squid/icons
    visible_hostname localhost
    cache_mgr admin@localhost
    access_log /var/squid/logs/access.log
    cache_log /var/squid/logs/cache.log
    cache_store_log none
    
    logfile_rotate 0
    shutdown_lifetime 3 seconds
    uri_whitespace strip
    
    acl dynamic urlpath_regex cgi-bin \?
    cache deny dynamic
    
    cache_mem 8 MB
    maximum_object_size_in_memory 32 KB
    memory_replacement_policy heap GDSF
    cache_replacement_policy heap LFUDA
    cache_dir ufs /var/squid/cache 100 16 256
    minimum_object_size 0 KB
    maximum_object_size 10 KB
    offline_mode off
    cache allow all
    
    # No redirector configured
    
    #Remote proxies
    
    # Setup some default acls
    # From 3.2 further configuration cleanups have been done to make things easier and safer. The manager, localhost, and to_localhost ACL definitions are now built-in.
    # acl localhost src 127.0.0.1/32
    acl allsrc src all
    acl safeports port 21 70 80 210 280 443 488 563 591 631 777 901  3128 3127 1025-65535 
    acl sslports port 443 563  
    
    # From 3.2 further configuration cleanups have been done to make things easier and safer. The manager, localhost, and to_localhost ACL definitions are now built-in.
    #acl manager proto cache_object
    
    acl purge method PURGE
    acl connect method CONNECT
    
    # Define protocols used for redirects
    acl HTTP proto HTTP
    acl HTTPS proto HTTPS
    http_access allow manager localhost
    
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !safeports
    http_access deny CONNECT !sslports
    
    # Always allow localhost connections
    # From 3.2 further configuration cleanups have been done to make things easier and safer. 
    # The manager, localhost, and to_localhost ACL definitions are now built-in.
    # http_access allow localhost
    
    request_body_max_size 0 KB
    delay_pools 1
    delay_class 1 2
    delay_parameters 1 -1/-1 -1/-1
    delay_initial_bucket_level 100
    delay_access 1 allow allsrc
    
    # Reverse Proxy settings
    http_port <wanip>:80 accel defaultsite= <domain.com>vhost
    https_port <wanip>:443 accel cert=/usr/local/etc/squid/518a4b9e2db8b.crt key=/usr/local/etc/squid/518a4b9e2db8b.key defaultsite= <domain.com>vhost
    #
    cache_peer <webserverip>parent 444 0 proxy-only no-query no-digest originserver login=PASS ssl sslflags=DONT_VERIFY_PEER front-end-https=auto name=rvp_maint
    
    acl rvm_maintgroup url_regex -i <domain.com>cache_peer_access rvp_maint allow rvm_maintgroup
    cache_peer_access rvp_maint deny allsrc
    never_direct allow rvm_maintgroup
    http_access allow rvm_maintgroup
    
    deny_info TCP_RESET allsrc
    
    # Custom options
    
    # Setup allowed acls
    # Default block all to be sure
    http_access deny allsrc</domain.com></webserverip></domain.com></wanip></domain.com></wanip></lanip> 
    ```</pid>

Log in to reply